Every CVE Search/ Get API key

CVE-2021-42220

Dolibarr Cross Site Scripting (XSS) vulnerability

5.4 MediumFix available

A Cross Site Scripting (XSS) vulnerability exists in Dolibarr before 14.0.3 via the ticket creation flow. Exploitation requires that an admin copies the payload into a box.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.98%Up 0.4 points since Dec 15, 2021
90%50%10%1%

What each source reports

NVD Score used 5.4

A Cross Site Scripting (XSS) vulnerability exists in Dolibarr before 14.0.3 via the ticket creation flow. Exploitation requires that an admin copies the payload into a box.

Record
CVE-2021-42220
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

A Cross Site Scripting (XSS) vulnerability exists in Dolibarr before 14.0.3 via the ticket creation flow. Exploitation requires that an admin copies the payload into a box.

Record
CVE-2021-42220
Updated
2026-11-02
EUVDEUVD-2021-2547 No score

A Cross Site Scripting (XSS) vulnerability exists in Dolibarr before 14.0.3 via the ticket creation flow. Exploitation requires that an admin copies the payload into a box.

Record
EUVD-2021-2547
Updated
2026-11-03
GitHub AdvisoriesGHSA-jqfp-m5f8-vg28 5.4

Dolibarr Cross Site Scripting (XSS) vulnerability

A Cross Site Scripting (XSS) vulnerability exists in Dolibarr before 14.0.3 via the ticket creation flow. Exploitation requires that an admin copies the payload into a box.

Record
GHSA-jqfp-m5f8-vg28
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-jqfp-m5f8-vg28 5.4

Dolibarr Cross Site Scripting (XSS) vulnerability

A Cross Site Scripting (XSS) vulnerability exists in Dolibarr before 14.0.3 via the ticket creation flow. Exploitation requires that an admin copies the payload into a box.

Record
GHSA-jqfp-m5f8-vg28
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2021-42220 5.4

A Cross Site Scripting (XSS) vulnerability exists in Dolibarr before 14.0.3 via the ticket creation flow. Exploitation requires that an admin copies the payload into a box.

Record
UBUNTU-CVE-2021-42220
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
dolibarr/dolibarr
Packagist
before 14.0.3
14.0.3
dolibarr/dolibarr
Packagist
before 14.0.3, plus listed versions
10.0.010.0.110.0.210.0.310.0.4
Show 45 moreShow less
10.0.510.0.610.0.711.0.011.0.111.0.211.0.311.0.411.0.512.0.012.0.112.0.212.0.312.0.412.0.513.0.013.0.113.0.213.0.313.0.413.0.514.0.014.0.114.0.23.6.03.6.0-beta3.6.13.6.23.6.33.6.43.6.53.6.63.7.03.7.13.7.23.7.33.7.43.8.03.8.0-beta3.8.13.8.23.8.33.8.43.9.03.9.0-rc
14.0.3
dolibarr
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.5.5+dfsg1-23.5.7+dfsg1-13.5.8+dfsg1-13.5.8+dfsg1-1ubuntu13.5.8+dfsg1-1ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-42220 is a medium vulnerability (CVSS 5.4) in Dolibarr, published December 15, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in dolibarr/dolibarr 14.0.3.

References

This page doesn't list everything

Left out here: 55 versions. The JSON record has them.

MoveEnter Open