Every CVE Search/ Get API key

CVE-2021-42700

Inkscape Out-of-bounds Read

3.3 LowFix available

Inkscape 0.91 is vulnerable to an out-of-bounds read, which may allow an attacker to have access to unauthorized information.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.81%Down 0.1 points since May 19, 2022
90%50%10%1%

What each source reports

CVE List Score used 3.3

Inkscape Out-of-bounds Read

Inkscape 0.91 is vulnerable to an out-of-bounds read, which may allow an attacker to have access to unauthorized information.

Record
CVE-2021-42700
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
EUVDEUVD-2021-29660 3.3

Inkscape 0.91 is vulnerable to an out-of-bounds read, which may allow an attacker to have access to unauthorized information.

Record
EUVD-2021-29660
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-gpxq-24pv-8cfg 3.3

Inkscape 0.19 is vulnerable to an out-of-bounds read, which may allow an attacker to have access...

Inkscape 0.19 is vulnerable to an out-of-bounds read, which may allow an attacker to have access to unauthorized information.

Record
GHSA-gpxq-24pv-8cfg
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
NVD 3.3

Inkscape 0.91 is vulnerable to an out-of-bounds read, which may allow an attacker to have access to unauthorized information.

Record
CVE-2021-42700
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:P/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
OSV 3.3

Inkscape 0.91 is vulnerable to an out-of-bounds read, which may allow an attacker to have access to unauthorized information.

Record
CVE-2021-42700
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2021-42700 3.3

Inkscape 0.91 is vulnerable to an out-of-bounds read, which may allow an attacker to have access to unauthorized information.

Record
DEBIAN-CVE-2021-42700
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2021-42700 3.3

Inkscape 0.91 is vulnerable to an out-of-bounds read, which may allow an attacker to have access to unauthorized information.

Record
UBUNTU-CVE-2021-42700
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
inkscape
Debian:12
before 1.0-1
1.0-1
inkscape
Debian:13
before 1.0-1
1.0-1
inkscape
Debian:14
before 1.0-1
1.0-1
inkscape
Ubuntu:16.04:LTS
All versions, plus listed versions
0.91-5ubuntu20.91-6ubuntu20.91-6ubuntu50.91-7ubuntu10.91-7ubuntu2
None known
inkscape
Ubuntu:18.04:LTS
All versions, plus listed versions
0.92.2-1build10.92.2-20.92.2-30.92.2-3build10.92.3~pre0-10.92.3-1
None known
inkscape
Ubuntu:20.04:LTS
All versions, plus listed versions
0.92.4-40.92.4-4build20.92.4-5ubuntu20.92.4-5ubuntu3.10.92.4-5ubuntu50.92.5-1ubuntu10.92.5-1ubuntu1.1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-42700 is a low vulnerability (CVSS 3.3) in Inkscape, published May 18, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.81%, the 57th percentile. Fixed in inkscape 1.0-1.

References

MoveEnter Open