CVE-2021-42704
Inkscape Out-of-bounds Write
Inkscape version 0.91 is vulnerable to an out-of-bounds write, which may allow an attacker to arbitrary execute code.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.8
Inkscape Out-of-bounds Write
Inkscape version 0.91 is vulnerable to an out-of-bounds write, which may allow an attacker to arbitrary execute code.
- Record
CVE-2021-42704- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2021-29664
7.8
Inkscape version 0.91 is vulnerable to an out-of-bounds write, which may allow an attacker to arbitrary execute code.
- Record
EUVD-2021-29664- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x8w5-m57q-vrj4
7.8
Inkscape version 0.19 is vulnerable to an out-of-bounds write, which may allow an attacker to...
Inkscape version 0.19 is vulnerable to an out-of-bounds write, which may allow an attacker to arbitrary execute code.
- Record
GHSA-x8w5-m57q-vrj4- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
NVD
7.8
Inkscape version 0.91 is vulnerable to an out-of-bounds write, which may allow an attacker to arbitrary execute code.
- Record
CVE-2021-42704- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
7.8
Inkscape version 0.91 is vulnerable to an out-of-bounds write, which may allow an attacker to arbitrary execute code.
- Record
CVE-2021-42704- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-42704
7.8
Inkscape version 0.91 is vulnerable to an out-of-bounds write, which may allow an attacker to arbitrary execute code.
- Record
DEBIAN-CVE-2021-42704- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-42704
7.8
Inkscape version 0.91 is vulnerable to an out-of-bounds write, which may allow an attacker to arbitrary execute code.
- Record
UBUNTU-CVE-2021-42704- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
inkscapeDebian:12 |
before 1.0-1 | 1.0-1 |
inkscapeDebian:13 |
before 1.0-1 | 1.0-1 |
inkscapeDebian:14 |
before 1.0-1 | 1.0-1 |
inkscapeUbuntu:16.04:LTS |
All versions, plus listed versions 0.91-5ubuntu20.91-6ubuntu20.91-6ubuntu50.91-7ubuntu10.91-7ubuntu2 |
None known |
inkscapeUbuntu:18.04:LTS |
All versions, plus listed versions 0.92.2-1build10.92.2-20.92.2-30.92.2-3build10.92.3~pre0-10.92.3-1 |
None known |
inkscapeUbuntu:20.04:LTS |
All versions, plus listed versions 0.92.4-40.92.4-4build20.92.4-5ubuntu20.92.4-5ubuntu3.10.92.4-5ubuntu50.92.5-1ubuntu10.92.5-1ubuntu1.1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-42704 is a high vulnerability (CVSS 7.8) in Inkscape, published May 18, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.55%, the 75th percentile. Fixed in inkscape 1.0-1.
References
cisa.gov/uscert/ics/advisories/icsa-22-132-03
integraxor.com/scada-animation-graphic-editor-extension-inkscape
nvd.nist.gov/vuln/detail/CVE-2021-42704
github.com/advisories/GHSA-x8w5-m57q-vrj4
security-tracker.debian.org/tracker/CVE-2021-42704
ubuntu.com/security/CVE-2021-42704
cve.org/CVERecord?id=CVE-2021-42704