CVE-2021-42767
Neo4j Graph Database vulnerable to Path Traversal
A directory traversal vulnerability in the apoc plugins in Neo4J Graph database before 4.4.0.1 allows attackers to read local files, and sometimes create local files. This is fixed in 3.5.17, 4.2.10, 4.3.0.4, and 4.4.0.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
9.1
A directory traversal vulnerability in the apoc plugins in Neo4J Graph database before 4.4.0.1 allows attackers to read local files, and sometimes create local files. This is fixed in 3.5.17, 4.2.10, 4.3.0.4, and 4.4.0.1.
- Record
CVE-2021-42767- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:P/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
A directory traversal vulnerability in the apoc plugins in Neo4J Graph database before 4.4.0.1 allows attackers to read local files, and sometimes create local files. This is fixed in 3.5.17, 4.2.10, 4.3.0.4, and 4.4.0.1.
- Record
CVE-2021-42767- Updated
- 2026-11-02
EUVDEUVD-2022-0817 No score
A directory traversal vulnerability in the apoc plugins in Neo4J Graph database before 4.4.0.1 allows attackers to read local files, and sometimes create local files. This is fixed in 3.5.17, 4.2.10, 4.3.0.4, and 4.4.0.1.
- Record
EUVD-2022-0817- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4mpj-488r-vh6m
9.1
Neo4j Graph Database vulnerable to Path Traversal
Impact
Directory Traversal Vulnerabilities found in several functions of apoc plugins in Neo4j Graph database. The attacker can retrieve and download files from outside the configured directory on the affected server. Under some circumstances, the attacker can also create files.
Patches
The users should aim to use the latest released version compatible with their Neo4j version. The minimum versions containing patch for this vulnerability (for Neo4j 4.2, 4.3, and 4.4 bundled with APOC, upgrade to the appropriate patched version): 3.5 - bundle n/a, standalone 3.5.0.17 4.2 - bundle 4.2.13, standalone 4.2.0.10 4.3 - bundle 4.3.9, standalone 4.3.0.4 4.4 - bundle 4.4.2, standalone 4.4.0.1
Workarounds
If you cannot upgrade the library, you can control the allowlist of the functions that can be used in your system:
For more information
If you have any questions or comments about this advisory:
- Open an issue in neo4j-apoc-procedures
- Email us at [email protected]
Credits
We want to publicly recognize the contribution of Nicolai Grødum from the Red Team of PwC Norway for reporting this issue and following the responsible disclosure policy.
- Record
GHSA-4mpj-488r-vh6m- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
9.1
A directory traversal vulnerability in the apoc plugins in Neo4J Graph database before 4.4.0.1 allows attackers to read local files, and sometimes create local files. This is fixed in 3.5.17, 4.2.10, 4.3.0.4, and 4.4.0.1.
- Record
CVE-2021-42767- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-4mpj-488r-vh6m
9.1
Neo4j Graph Database vulnerable to Path Traversal
Impact
Directory Traversal Vulnerabilities found in several functions of apoc plugins in Neo4j Graph database. The attacker can retrieve and download files from outside the configured directory on the affected server. Under some circumstances, the attacker can also create files.
Patches
The users should aim to use the latest released version compatible with their Neo4j version. The minimum versions containing patch for this vulnerability (for Neo4j 4.2, 4.3, and 4.4 bundled with APOC, upgrade to the appropriate patched version): 3.5 - bundle n/a, standalone 3.5.0.17 4.2 - bundle 4.2.13, standalone 4.2.0.10 4.3 - bundle 4.3.9, standalone 4.3.0.4 4.4 - bundle 4.4.2, standalone 4.4.0.1
Workarounds
If you cannot upgrade the library, you can control the allowlist of the functions that can be used in your system:
For more information
If you have any questions or comments about this advisory:
- Open an issue in neo4j-apoc-procedures
- Email us at [email protected]
Credits
We want to publicly recognize the contribution of Nicolai Grødum from the Red Team of PwC Norway for reporting this issue and following the responsible disclosure policy.
- Record
GHSA-4mpj-488r-vh6m- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.neo4j.procedure:apocMaven |
before 3.5.17 | 3.5.17 |
org.neo4j.procedure:apocMaven |
4.2.0 up to 4.2.10 | 4.2.10 |
org.neo4j.procedure:apocMaven |
4.3.0.0 to 4.3.0.3 | 4.3.0.4 |
org.neo4j.procedure:apocMaven |
4.4.0.0 to 4.4.0.0 | 4.4.0.1 |
org.neo4j.procedure:apocMaven |
before 3.5.17, plus listed versions 1.0.01.0.0-RC11.1.03.0.4.13.0.4.2 Show 41 moreShow less3.0.8.43.0.8.53.1.0.23.1.0.33.1.0.43.1.0.53.1.2.53.1.3.73.1.3.83.1.3.93.2.0.13.2.0.43.2.3.53.2.3.63.3.0.13.3.0.23.3.0.33.3.0.43.4.0.13.4.0.23.4.0.33.4.0.43.4.0.53.4.0.73.5.0.13.5.0.103.5.0.113.5.0.123.5.0.133.5.0.143.5.0.153.5.0.173.5.0.183.5.0.193.5.0.23.5.0.203.5.0.213.5.0.43.5.0.53.5.0.63.5.0.7 |
3.5.17 |
org.neo4j.procedure:apocMaven |
4.2.0 up to 4.2.10, plus listed versions 4.2.0.04.2.0.14.2.0.104.2.0.114.2.0.12 Show 8 moreShow less4.2.0.24.2.0.34.2.0.44.2.0.54.2.0.64.2.0.74.2.0.84.2.0.9 |
4.2.10 |
org.neo4j.procedure:apocMaven |
4.3.0.0 up to 4.3.0.4, plus listed versions 4.3.0.14.3.0.24.3.0.3 |
4.3.0.4 |
org.neo4j.procedure:apocMaven |
4.4.0.0 up to 4.4.0.1 | 4.4.0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-42767 is a critical vulnerability (CVSS 9.1) in Neo4j Awesome Procedures, published February 1, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.53%, the 74th percentile. Fixed in org.neo4j.procedure:apoc 3.5.17.