Every CVE Search/ Get API key

CVE-2021-42917

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of...

5.5 MediumFix available

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.90%Up 0.6 points since Nov 2, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.

Record
CVE-2021-42917
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.

Record
CVE-2021-42917
Updated
2026-11-02
EUVDEUVD-2021-29872 No score

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.

Record
EUVD-2021-29872
Updated
2026-11-03
GitHub AdvisoriesGHSA-9856-v5xm-mr4c 5.5

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of...

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.

Record
GHSA-9856-v5xm-mr4c
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-120
Updated
2026-11-02
OSV 5.5

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.

Record
CVE-2021-42917
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-42917 5.5

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.

Record
DEBIAN-CVE-2021-42917
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-42917 5.5

Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.

Record
UBUNTU-CVE-2021-42917
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kodi
Debian:12
before 2:19.3+dfsg1-1
2:19.3+dfsg1-1
kodi
Debian:13
before 2:19.3+dfsg1-1
2:19.3+dfsg1-1
kodi
Debian:14
before 2:19.3+dfsg1-1
2:19.3+dfsg1-1
kodi
Debian:10
From an advisory covering 4 CVEs
before 2:17.6+dfsg1-4+deb10u1, plus listed versions
2:17.6+dfsg1-4
2:17.6+dfsg1-4+deb10u1
kodi
Ubuntu:16.04:LTS
All versions, plus listed versions
15.1+dfsg1-315.2+dfsg1-1build115.2+dfsg1-315.2+dfsg1-3ubuntu115.2+dfsg1-3ubuntu1.1
None known
kodi
Ubuntu:18.04:LTS
All versions, plus listed versions
2:17.3+dfsg1-32:17.3+dfsg1-3build12:17.3+dfsg1-52:17.3+dfsg1-5build12:17.3+dfsg1-5build22:17.6+dfsg1-12:17.6+dfsg1-1build12:17.6+dfsg1-1ubuntu1
None known
kodi
Ubuntu:20.04:LTS
All versions, plus listed versions
2:17.6+dfsg1-4ubuntu42:17.6+dfsg1-4ubuntu92:17.6+dfsg1-4ubuntu102:18.5+dfsg1-0ubuntu32:18.6+dfsg1-2ubuntu1
None known
kodi
Ubuntu:22.04:LTS
All versions, plus listed versions
2:19.1+dfsg2-22:19.3+dfsg1-12:19.3+dfsg1-1build22:19.3+dfsg1-1build32:19.3+dfsg1-1build42:19.3+dfsg1-1build52:19.4+dfsg1-2
None known
kodi
Ubuntu:24.04:LTS
All versions, plus listed versions
2:20.2+dfsg-42:20.2+dfsg-4build12:20.2+dfsg-4build22:20.2+dfsg-4ubuntu12:20.3+dfsg-12:20.4+dfsg-12:20.5+dfsg-1build22:20.5+dfsg-1ubuntu1
None known
kodi
Ubuntu:25.10
All versions, plus listed versions
2:21.2+dfsg-1build22:21.2+dfsg-42:21.2+dfsg-4build12:21.2+dfsg-4build2
None known
kodi
Ubuntu:26.10
All versions, plus listed versions
2:21.3+dfsg-1ubuntu12:21.3+dfsg-1.2
None known
kodi
Ubuntu:26.04:LTS
All versions, plus listed versions
2:21.2+dfsg-4build22:21.2+dfsg-4build32:21.2+dfsg-52:21.3+dfsg-12:21.3+dfsg-1build12:21.3+dfsg-1ubuntu1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-42917 is a medium vulnerability (CVSS 5.5) in Kodi, published November 1, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.90%, the 79th percentile. Fixed in kodi 2:19.3+dfsg1-1.

References

Show 5 moreShow less
MoveEnter Open