Every CVE Search/ Get API key

CVE-2021-43518

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not...

7.8 HighFix available

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer a specially crafted map that will overwrite client's stack causing denial of service or code execution.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.43%Up 0.1 points since Dec 16, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer a specially crafted map that will overwrite client's stack causing denial of service or code execution.

Record
CVE-2021-43518
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer a specially crafted map that will overwrite client's stack causing denial of service or code execution.

Record
CVE-2021-43518
Updated
2026-11-02
EUVDEUVD-2021-30447 No score

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer a specially crafted map that will overwrite client's stack causing denial of service or code execution.

Record
EUVD-2021-30447
Updated
2026-11-03
GitHub AdvisoriesGHSA-53xw-cwmg-3m36 7.8

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not...

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer a specially crafted map that will overwrite client's stack causing denial of service or code execution.

Record
GHSA-53xw-cwmg-3m36
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
OSV 7.8

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer a specially crafted map that will overwrite client's stack causing denial of service or code execution.

Record
CVE-2021-43518
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-43518 7.8

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer a specially crafted map that will overwrite client's stack causing denial of service or code execution.

Record
DEBIAN-CVE-2021-43518
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-43518 7.8

Teeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer a specially crafted map that will overwrite client's stack causing denial of service or code execution.

Record
UBUNTU-CVE-2021-43518
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2022-0292 No score

Updated teeworlds packages fix security vulnerability

Code execution via malicious map file (CVE-2021-43518)

Record
MGASA-2022-0292
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
teeworlds
Debian:12
before 0.7.5-2
0.7.5-2
teeworlds
Debian:13
before 0.7.5-2
0.7.5-2
teeworlds
Debian:14
before 0.7.5-2
0.7.5-2
teeworlds
Mageia:8
before 0.7.5-1.1.mga8
0.7.5-1.1.mga8
teeworlds
Ubuntu:20.04:LTS
All versions, plus listed versions
0.7.2-50.7.2-5ubuntu10.7.2-5ubuntu1.1
None known
teeworlds
Ubuntu:22.04:LTS
All versions, plus listed versions
0.7.5-1
None known
teeworlds
Ubuntu:24.04:LTS
before 0.7.5-2
0.7.5-2
teeworlds
Ubuntu:25.10
before 0.7.5-2
0.7.5-2
teeworlds
Ubuntu:26.04:LTS
before 0.7.5-2
0.7.5-2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-43518 is a high vulnerability (CVSS 7.8) in Teeworlds, published December 15, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.43%, the 73rd percentile. Fixed in teeworlds 0.7.5-2.

References

Show 8 moreShow less
MoveEnter Open