CVE-2021-43676
Path manipulation in matyhtf/framework
matyhtf framework v3.0.5 is affected by a path manipulation vulnerability in Smarty.class.php.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
matyhtf framework v3.0.5 is affected by a path manipulation vulnerability in Smarty.class.php.
- Record
CVE-2021-43676- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
matyhtf framework v3.0.5 is affected by a path manipulation vulnerability in Smarty.class.php.
- Record
CVE-2021-43676- Updated
- 2026-11-02
EUVDEUVD-2021-2555 No score
matyhtf framework v3.0.5 is affected by a path manipulation vulnerability in Smarty.class.php.
- Record
EUVD-2021-2555- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mh9j-v6mq-pfch
9.8
Path manipulation in matyhtf/framework
matyhtf framework v3.0.5 is affected by a path manipulation vulnerability in Smarty.class.php. The issue was fixed in version 3.0.6.
- Record
GHSA-mh9j-v6mq-pfch- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVGHSA-mh9j-v6mq-pfch
9.8
Path manipulation in matyhtf/framework
matyhtf framework v3.0.5 is affected by a path manipulation vulnerability in Smarty.class.php. The issue was fixed in version 3.0.6.
- Record
GHSA-mh9j-v6mq-pfch- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
matyhtf/frameworkPackagist |
before 3.0.6 | 3.0.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-43676 is a critical vulnerability (CVSS 9.8) in Swoole Php Framework, published December 3, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.43%, the 73rd percentile. Fixed in matyhtf/framework 3.0.6.
References
github.com/matyhtf/framework/issues/206
nvd.nist.gov/vuln/detail/CVE-2021-43676
github.com/matyhtf/framework/commit/25084603b7ea771eebe263d39744fe6abf1f8d61
github.com/FriendsOfPHP/security-advisories/blob/master/matyhtf/framework/CVE-2021-43676.yaml
github.com/advisories/GHSA-mh9j-v6mq-pfch
github.com/matyhtf/framework