CVE-2021-43811
Code injection via unsafe YAML loading
Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.8
Code injection via unsafe YAML loading
Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.
- Record
CVE-2021-43811- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2021-0247
7.8
Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.
- Record
EUVD-2021-0247- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-ggmr-44cv-24pm
7.8
Code injection via unsafe YAML loading
Impact
Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files.
An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally.
Patches
The issue is fixed in version 2.3.24 and above by #964.
For more information
If you have any questions or comments about this advisory:
- Open an issue in awslabs/sockeye
- Email us at sockeye-dev
Attribution
This vulnerability was reported by Masatoshi Yoshizawa of yamory Security Team.
- Record
GHSA-ggmr-44cv-24pm- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
NVD
7.8
Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.
- Record
CVE-2021-43811- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
7.8
Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.
- Record
CVE-2021-43811- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-ggmr-44cv-24pm
7.8
Code injection via unsafe YAML loading
Impact
Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files.
An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally.
Patches
The issue is fixed in version 2.3.24 and above by #964.
For more information
If you have any questions or comments about this advisory:
- Open an issue in awslabs/sockeye
- Email us at sockeye-dev
Attribution
This vulnerability was reported by Masatoshi Yoshizawa of yamory Security Team.
- Record
GHSA-ggmr-44cv-24pm- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVPYSEC-2021-848 No score
Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.
- Record
PYSEC-2021-848- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
sockeyePyPI |
before 2.3.24 | 2.3.24 |
sockeyePyPI |
before 2.3.24, plus listed versions 1.0.11.0.21.0.31.1.11.10.1 Show 45 moreShow less1.10.31.10.41.10.51.13.01.15.51.15.61.15.71.15.81.16.01.16.11.16.21.17.01.17.21.17.41.18.11.18.101.18.1061.18.131.18.151.18.171.18.201.18.211.18.221.18.231.18.281.18.351.18.411.18.471.18.51.18.541.18.561.18.571.18.61.18.611.18.671.18.721.18.781.18.81.18.851.18.91.18.921.18.931.18.971.5.11.7.1 |
2.3.24 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | s-index/CVE-2021-43811 | 2022-08-21 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-43811 is a high vulnerability (CVSS 7.8) in Amazon Sockeye, published December 8, 2021. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 2.47%, the 84th percentile. Fixed in sockeye 2.3.24.
References
github.com/awslabs/sockeye/security/advisories/GHSA-ggmr-44cv-24pm
github.com/awslabs/sockeye/pull/964
github.com/awslabs/sockeye/releases/tag/2.3.24
nvd.nist.gov/vuln/detail/CVE-2021-43811
github.com/pypa/advisory-database/tree/main/vulns/sockeye/PYSEC-2021-848.yaml
github.com/advisories/GHSA-ggmr-44cv-24pm
github.com/awslabs/sockeye
Left out here: 14 versions. The JSON record has them.