CVE-2021-43857
Gerapy may contain remote code execution vulnerability
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
Gerapy may contain remote code execution vulnerability
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
- Record
CVE-2021-43857- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2021-0092
9.8
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
- Record
EUVD-2021-0092- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9w7f-m4j4-j3xw
9.3
Gerapy may cause remote code execution
Impact
project_configure function exist remote code execute in Gerapy < 0.9.8
Patches
Patched in version 0.9.8, please install with:
pip3 install -U gerapy
- Record
GHSA-9w7f-m4j4-j3xw- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
NVD
9.8
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
- Record
CVE-2021-43857- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
8.8
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
- Record
CVE-2021-43857- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-9w7f-m4j4-j3xw
9.3
Gerapy may cause remote code execution
Impact
project_configure function exist remote code execute in Gerapy < 0.9.8
Patches
Patched in version 0.9.8, please install with:
pip3 install -U gerapy
- Record
GHSA-9w7f-m4j4-j3xw- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSVPYSEC-2021-867 No score
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
- Record
PYSEC-2021-867- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gerapyPyPI |
before 0.9.8 | 0.9.8 |
gerapyPyPI |
before 0.9.8, plus listed versions 0.6.60.6.70.6.80.6.90.7.0 Show 35 moreShow less0.7.10.7.20.7.30.7.60.7.70.7.80.7.90.8.00.8.10.8.20.8.30.8.4rc20.8.50.8.5rc20.8.60.8.6a00.8.6b00.8.6b10.8.6rc10.8.6rc20.8.70.8.80.9.00.9.10.9.20.9.2a00.9.2rc10.9.30.9.3a10.9.3a20.9.3b10.9.50.9.60.9.6a10.9.7 |
0.9.8 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Gerapy 0.9.7 - Remote Code Execution (RCE) (Authenticated) | 2022-01-05 |
| PoC in GitHub | G4sp4rCS/CVE-2021-43857-POC | 2025-04-24 |
| PoC in GitHub | LongWayHomie/CVE-2021-43857 | 2022-01-03 |
| PoC in GitHub | ProwlSec/gerapy-cve-2021-43857 | 2025-07-29 |
| PoC in GitHub | afifudinmtop/CVE-2021-43857-Gerapy-v0.9.7 | 2026-01-30 |
| PoC in GitHub | lowkey0808/CVE-2021-43857 | 2022-04-26 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-43857 is a critical vulnerability (CVSS 9.8) in Gerapy, published December 27, 2021. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 55.6%, the 99th percentile. Fixed in gerapy 0.9.8.
References
github.com/Gerapy/Gerapy/issues/219
github.com/Gerapy/Gerapy/security/advisories/GHSA-9w7f-m4j4-j3xw
github.com/Gerapy/Gerapy/commit/49bcb19be5e0320e7e1535f34fe00f16a3cf3b28
packetstormsecurity.com/files/165459/Gerapy-0.9.7-Remote-Code-Execution.html
nvd.nist.gov/vuln/detail/CVE-2021-43857
github.com/pypa/advisory-database/tree/main/vulns/gerapy/PYSEC-2022-228.yaml
github.com/pypa/advisory-database/tree/main/vulns/gerapy/PYSEC-2021-867.yaml
github.com/advisories/GHSA-9w7f-m4j4-j3xw
github.com/Gerapy/Gerapy