Every CVE Search/ Get API key

CVE-2021-44118

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the...

5.4 MediumFix available

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.77%Down 0.1 points since Jan 27, 2022
90%50%10%1%

What each source reports

NVD Score used 5.4

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

Record
CVE-2021-44118
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

Record
CVE-2021-44118
Updated
2026-11-02
EUVDEUVD-2021-30974 No score

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

Record
EUVD-2021-30974
Updated
2026-11-03
GitHub AdvisoriesGHSA-564r-594w-gw2m No score

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the...

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

Record
GHSA-564r-594w-gw2m
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

Record
CVE-2021-44118
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2021-44118 5.4

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

Record
DEBIAN-CVE-2021-44118
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2021-44118 5.4

SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

Record
UBUNTU-CVE-2021-44118
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUSN-5482-1 No score

spip vulnerabilities

It was discovered that SPIP incorrectly validated inputs. An authenticated attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. (CVE-2020-28984)

Charles Fol and Théo Gordyjan discovered that SPIP is vulnerable to Cross Site Scripting (XSS). If a user were tricked into browsing a malicious SVG file, an attacker could possibly exploit this issue to execute arbitrary code. This issue was only fixed in Ubuntu 21.10. (CVE-2021-44118, CVE-2021-44120, CVE-2021-44122, CVE-2021-44123)

It was discovered that SPIP incorrectly handled certain forms. A remote authenticated editor could possibly use this issue to execute arbitrary code, and a remote unauthenticated attacker could possibly use this issue to obtain sensitive information. (CVE-2022-26846, CVE-2022-26847)

Record
USN-5482-1
Updated
2026-11-02
OSVUSN-5482-2 No score

spip vulnerabilities

USN-5482-1 fixed several vulnerabilities in SPIP. This update provides the corresponding updates for Ubuntu 20.04 LTS for CVE-2021-44118, CVE-2021-44120, CVE-2021-44122 and CVE-2021-44123.

Original advisory details:

It was discovered that SPIP incorrectly validated inputs. An authenticated attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. (CVE-2020-28984)

Charles Fol and Théo Gordyjan discovered that SPIP is vulnerable to Cross Site Scripting (XSS). If a user were tricked into browsing a malicious SVG file, an attacker could possibly exploit this issue to execute arbitrary code. This issue was only fixed in Ubuntu 21.10. (CVE-2021-44118, CVE-2021-44120, CVE-2021-44122, CVE-2021-44123)

It was discovered that SPIP incorrectly handled certain forms. A remote authenticated editor could possibly use this issue to execute arbitrary code, and a remote unauthenticated attacker could possibly use this issue to obtain sensitive information. (CVE-2022-26846, CVE-2022-26847)

Record
USN-5482-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
spip
Debian:13
before 3.2.12-1
3.2.12-1
spip
Debian:14
before 3.2.12-1
3.2.12-1
spip
Debian:9
From an advisory covering 4 CVEs
before 3.1.4-4~deb9u4+deb9u2, plus listed versions
3.1.4-23.1.4-33.1.4-3~deb9u13.1.4-4~deb9u13.1.4-4~deb9u23.1.4-4~deb9u33.1.4-4~deb9u43.1.4-4~deb9u4+deb9u1
3.1.4-4~deb9u4+deb9u2
spip
Debian:10
From an advisory covering 4 CVEs
before 3.2.4-1+deb10u5, plus listed versions
3.2.4-13.2.4-1+deb10u13.2.4-1+deb10u23.2.4-1+deb10u33.2.4-1+deb10u4
3.2.4-1+deb10u5
spip
Debian:11
From an advisory covering 4 CVEs
before 3.2.11-3+deb11u1, plus listed versions
3.2.11-3
3.2.11-3+deb11u1
spip
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.0.20-13.0.21-13.0.21-1ubuntu13.0.21-1ubuntu1+esm1
None known
spip
Ubuntu:18.04:LTS
before 3.1.4-4~deb9u5build0.18.04.1, plus listed versions
3.1.4-33.1.4-4~deb9u3build0.18.04.1
3.1.4-4~deb9u5build0.18.04.1
spip
Ubuntu:20.04:LTS
before 3.2.7-1ubuntu0.1, plus listed versions
3.2.4-13.2.5-13.2.7-1
3.2.7-1ubuntu0.1
spip
Ubuntu:18.04:LTS
From an advisory covering 7 CVEs
before 3.1.4-4~deb9u5build0.18.04.1, plus listed versions
3.1.4-33.1.4-4~deb9u3build0.18.04.1
3.1.4-4~deb9u5build0.18.04.1
spip
Ubuntu:20.04:LTS
From an advisory covering 4 CVEs
before 3.2.7-1ubuntu0.1, plus listed versions
3.2.4-13.2.5-13.2.7-1
3.2.7-1ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-44118 is a medium vulnerability (CVSS 5.4) in Spip, published December 22, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.77%, the 55th percentile. Fixed in spip 3.2.12-1.

References

Show 10 moreShow less
MoveEnter Open