CVE-2021-44223
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for...
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.1
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Record
CVE-2021-44223- CVSS 3.1
- 8.1 High
CVSS:3.1/AC:H/AV:N/A:H/C:H/I:H/PR:N/S:U/UI:N - Updated
- 2026-11-02
EUVDEUVD-2021-31072
8.1
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Record
EUVD-2021-31072- CVSS 3.1
- 8.1 High
CVSS:3.1/AC:H/AV:N/A:H/C:H/I:H/PR:N/S:U/UI:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m8cv-g4gv-cx2g No score
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for...
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Record
GHSA-m8cv-g4gv-cx2g- Updated
- 2026-11-02
NVD
8.1
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Record
CVE-2021-44223- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
OSV
9.8
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Record
CVE-2021-44223- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-44223
9.8
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Record
DEBIAN-CVE-2021-44223- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-44223
8.1
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Record
UBUNTU-CVE-2021-44223- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-wordpress-2021-44223 No score
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Record
BIT-wordpress-2021-44223- Updated
- 2026-11-02
OSVBIT-wordpress-multisite-2021-44223 No score
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Record
BIT-wordpress-multisite-2021-44223- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressBitnami |
before 5.8.0 | 5.8.0 |
wordpress-multisiteBitnami |
before 5.8.0 | 5.8.0 |
wordpressDebian:12 |
before 5.8.1+dfsg1-1 | 5.8.1+dfsg1-1 |
wordpressDebian:13 |
before 5.8.1+dfsg1-1 | 5.8.1+dfsg1-1 |
wordpressDebian:14 |
before 5.8.1+dfsg1-1 | 5.8.1+dfsg1-1 |
wordpressUbuntu:16.04:LTS |
All versions, plus listed versions 4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1 |
None known |
wordpressUbuntu:18.04:LTS |
All versions, plus listed versions 4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1 |
None known |
wordpressUbuntu:20.04:LTS |
All versions, plus listed versions 5.2.2+dfsg1-15.2.4+dfsg1-15.3.2+dfsg1-15.3.2+dfsg1-1ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-44223 is a high vulnerability (CVSS 8.1) in Wordpress, published November 25, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 29.0%, the 98th percentile. Fixed in wordpress 5.8.0.
References
vavkamil.cz/2021/11/25/wordpress-plugin-confusion-update-can-get-you-pwned
make.wordpress.org/core/2021/06/29/introducing-update-uri-plugin-header-in-wordpress-5-8
nvd.nist.gov/vuln/detail/CVE-2021-44223
github.com/advisories/GHSA-m8cv-g4gv-cx2g
security-tracker.debian.org/tracker/CVE-2021-44223
ubuntu.com/security/CVE-2021-44223
cve.org/CVERecord?id=CVE-2021-44223