CVE-2021-44550
Access Control vulnerability within CoreNLP
An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).
- Record
CVE-2021-44550- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-74
- Updated
- 2026-11-02
CVE List No score
An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).
- Record
CVE-2021-44550- Updated
- 2026-11-02
EUVDEUVD-2022-1244 No score
An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).
- Record
EUVD-2022-1244- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x2p8-rgfm-qw3v
9.8
Access Control vulnerability within CoreNLP
An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).
- Record
GHSA-x2p8-rgfm-qw3v- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-863
- Updated
- 2026-11-02
OSV
9.8
An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).
- Record
CVE-2021-44550- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-x2p8-rgfm-qw3v
9.8
Access Control vulnerability within CoreNLP
An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).
- Record
GHSA-x2p8-rgfm-qw3v- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-863
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
edu.stanford.nlp:stanford-corenlpMaven |
through 4.3.2 | 4.4.0 |
edu.stanford.nlp:stanford-corenlpMaven |
before 4.4.0, plus listed versions 1.2.01.3.01.3.11.3.21.3.3 Show 22 moreShow less1.3.41.3.53.2.03.3.03.3.13.43.4.13.5.03.5.13.5.23.6.03.7.03.8.03.9.13.9.24.0.04.2.04.2.14.2.24.3.04.3.14.3.2 |
4.4.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-44550 is a critical vulnerability (CVSS 9.8) in Stanford Corenlp, published February 23, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.29%, the 70th percentile. Fixed in edu.stanford.nlp:stanford-corenlp 4.4.0.