Every CVE Search/ Get API key

CVE-2021-44649

Cross-site Scripting in django-cms

5.4 MediumFix available

Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.64%Unchanged since Jan 13, 2022
90%50%10%1%

What each source reports

NVD Score used 5.4

Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.

Record
CVE-2021-44649
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.

Record
CVE-2021-44649
Updated
2026-11-02
EUVDEUVD-2022-0079 No score

Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.

Record
EUVD-2022-0079
Updated
2026-11-03
GitHub AdvisoriesGHSA-hx7c-qpfq-xcrp 5.1

Cross-site Scripting in django-cms

Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.

Record
GHSA-hx7c-qpfq-xcrp
CVSS 4.0
5.1 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.

Record
CVE-2021-44649
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-hx7c-qpfq-xcrp 5.1

Cross-site Scripting in django-cms

Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.

Record
GHSA-hx7c-qpfq-xcrp
CVSS 4.0
5.1 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2022-7 No score

Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.

Record
PYSEC-2022-7
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
django-cms
PyPI
3.7.0 up to 3.7.4
3.7.4
django-cms
PyPI
3.6.0 up to 3.6.1
3.6.1
django-cms
PyPI
3.5.0 up to 3.5.4
3.5.4
django-cms
PyPI
3.4.0 up to 3.4.7
3.4.7
django-cms
PyPI
3.7.0 up to 3.7.4, plus listed versions
3.7.13.7.23.7.3
3.7.4
django-cms
PyPI
3.5.0 up to 3.5.4, plus listed versions
3.5.13.5.23.5.3
3.5.4
django-cms
PyPI
3.4.0 up to 3.4.7, plus listed versions
3.4.13.4.23.4.33.4.43.4.53.4.6
3.4.7
django-cms
PyPI
3.4.0 up to 3.4.7, 3.5.0 up to 3.5.4, 3.6.0 up to 3.6.1, 3.7.0 up to 3.7.4, plus listed versions
3.4.13.4.23.4.33.4.43.4.5
Show 7 moreShow less
3.4.63.5.13.5.23.5.33.7.13.7.23.7.3
3.4.73.5.43.6.13.7.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-44649 is a medium vulnerability (CVSS 5.4) in Django-cms Django Cms, published January 12, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.64%, the 50th percentile. Fixed in django-cms 3.7.4.

References

MoveEnter Open