Every CVE Search/ Get API key

CVE-2021-44917

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c,...

5.5 MediumFix available

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c, which could cause a Arithmetic exception and application crash.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.75%Up 0.3 points since Dec 22, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c, which could cause a Arithmetic exception and application crash.

Record
CVE-2021-44917
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-369
Updated
2026-11-02
CVE List No score

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c, which could cause a Arithmetic exception and application crash.

Record
CVE-2021-44917
Updated
2026-11-02
EUVDEUVD-2021-31715 No score

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c, which could cause a Arithmetic exception and application crash.

Record
EUVD-2021-31715
Updated
2026-11-03
GitHub AdvisoriesGHSA-54h4-5526-7jv6 5.5

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c,...

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c, which could cause a Arithmetic exception and application crash.

Record
GHSA-54h4-5526-7jv6
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-369
Updated
2026-11-02
OSV 5.5

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c, which could cause a Arithmetic exception and application crash.

Record
CVE-2021-44917
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-44917 5.5

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c, which could cause a Arithmetic exception and application crash.

Record
DEBIAN-CVE-2021-44917
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-44917 5.5

A Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c, which could cause a Arithmetic exception and application crash.

Record
UBUNTU-CVE-2021-44917
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11723-1 No score

gnuplot-5.4.3-1.1 on GA media

These are all security issues fixed in the gnuplot-5.4.3-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11723-1
Updated
2026-11-02
OSVUSN-7589-1 No score

gnuplot vulnerabilities

Tim Blazytko, Cornelius Aschermann, Sergej Schumilo, and Nils Bars discovered that Gnuplot had several memory-related issues. An attacker could possibly use these issues to cause Gnuplot to experience a buffer overflow, resulting in a denial of service or arbitrary code execution. These issues only affected Ubuntu 14.04 LTS and Ubuntu 18.04 LTS. (CVE-2018-19490, CVE-2018-19491, CVE-2018-19492)

It was discovered that Gnuplot could write out-of-bounds due to the use of strncpy(). An attacker could possibly use this issue to enable the execution of arbitrary code. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-25412)

It was discovered that Gnuplot incorrectly freed memory when executing print_set_output(). An attacker could possibly use this issue to enable the execution of arbitrary code. (CVE-2020-25559)

It was discovered that Gnuplot's plotrequest() function contained a buffer overflow. An attacker could possibly use this issue to cause Gnuplot to crash, resulting in a denial of service or arbitrary code execution. (CVE-2020-25969)

It was discovered that Gnuplot's boundary3d() function could be made to divide by zero. An attacker could possibly use this issue to cause Gnuplot to crash, resulting in a denial of service. (CVE-2021-44917)

Record
USN-7589-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnuplot
Debian:12
before 5.4.2+dfsg2-2
5.4.2+dfsg2-2
gnuplot
Debian:13
before 5.4.2+dfsg2-2
5.4.2+dfsg2-2
gnuplot
Debian:14
before 5.4.2+dfsg2-2
5.4.2+dfsg2-2
gnuplot
Ubuntu:Pro:14.04:LTS
before 4.6.4-2ubuntu0.1~esm1, plus listed versions
4.6.3-24.6.4-14.6.4-2
4.6.4-2ubuntu0.1~esm1
gnuplot
Ubuntu:Pro:16.04:LTS
before 4.6.6-3ubuntu0.1+esm1, plus listed versions
4.6.6-24.6.6-34.6.6-3ubuntu0.1
4.6.6-3ubuntu0.1+esm1
gnuplot
Ubuntu:Pro:18.04:LTS
before 5.2.2+dfsg1-2ubuntu1+esm1, plus listed versions
5.0.7+dfsg1-15.2.2+dfsg1-25.2.2+dfsg1-2ubuntu1
5.2.2+dfsg1-2ubuntu1+esm1
gnuplot
Ubuntu:Pro:20.04:LTS
before 5.2.8+dfsg1-2ubuntu0.1~esm1, plus listed versions
5.2.6+dfsg1-25.2.7+dfsg1-65.2.8+dfsg1-15.2.8+dfsg1-2
5.2.8+dfsg1-2ubuntu0.1~esm1
gnuplot
Ubuntu:Pro:14.04:LTS
From an advisory covering 7 CVEs
before 4.6.4-2ubuntu0.1~esm1, plus listed versions
4.6.3-24.6.4-14.6.4-2
4.6.4-2ubuntu0.1~esm1
gnuplot
Ubuntu:Pro:16.04:LTS
From an advisory covering 7 CVEs
before 4.6.6-3ubuntu0.1+esm1, plus listed versions
4.6.6-24.6.6-34.6.6-3ubuntu0.1
4.6.6-3ubuntu0.1+esm1
gnuplot
Ubuntu:Pro:18.04:LTS
From an advisory covering 7 CVEs
before 5.2.2+dfsg1-2ubuntu1+esm1, plus listed versions
5.0.7+dfsg1-15.2.2+dfsg1-25.2.2+dfsg1-2ubuntu1
5.2.2+dfsg1-2ubuntu1+esm1
gnuplot
Ubuntu:Pro:20.04:LTS
From an advisory covering 7 CVEs
before 5.2.8+dfsg1-2ubuntu0.1~esm1, plus listed versions
5.2.6+dfsg1-25.2.7+dfsg1-65.2.8+dfsg1-15.2.8+dfsg1-2
5.2.8+dfsg1-2ubuntu0.1~esm1
gnuplot
openSUSE:Tumbleweed
before 5.4.3-1.1
5.4.3-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-44917 is a medium vulnerability (CVSS 5.5) in Gnuplot, published December 21, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.75%, the 55th percentile. Fixed in gnuplot 5.4.2+dfsg2-2.

References

Show 14 moreShow less
MoveEnter Open