Every CVE Search/ Get API key

CVE-2021-45911

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main...

7.8 HighFix available

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main function. It allows an attacker to write 2 bytes outside the boundaries of the buffer.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.90%Up 0.5 points since Dec 28, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main function. It allows an attacker to write 2 bytes outside the boundaries of the buffer.

Record
CVE-2021-45911
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main function. It allows an attacker to write 2 bytes outside the boundaries of the buffer.

Record
CVE-2021-45911
Updated
2026-11-02
EUVDEUVD-2021-32626 No score

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main function. It allows an attacker to write 2 bytes outside the boundaries of the buffer.

Record
EUVD-2021-32626
Updated
2026-11-03
GitHub AdvisoriesGHSA-2pj8-x98c-rm2q 7.8

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main...

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main function. It allows an attacker to write 2 bytes outside the boundaries of the buffer.

Record
GHSA-2pj8-x98c-rm2q
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 7.8

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main function. It allows an attacker to write 2 bytes outside the boundaries of the buffer.

Record
CVE-2021-45911
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-45911 7.8

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main function. It allows an attacker to write 2 bytes outside the boundaries of the buffer.

Record
DEBIAN-CVE-2021-45911
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-45911 7.8

An issue was discovered in gif2apng 1.9. There is a heap-based buffer overflow in the main function. It allows an attacker to write 2 bytes outside the boundaries of the buffer.

Record
UBUNTU-CVE-2021-45911
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-5969-1 No score

gif2apng vulnerabilities

It was discovered that gif2apng contained multiple heap-base overflows. An attacker could potentially exploit this to cause a denial of service (system crash). (CVE-2021-45909, CVE-2021-45910, CVE-2021-45911)

Record
USN-5969-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gif2apng
Debian:11
before 1.9+srconly-3+deb11u1, plus listed versions
1.9+srconly-3
1.9+srconly-3+deb11u1
gif2apng
Debian:9
From an advisory covering 3 CVEs
before 1.9+srconly-2+deb9u2, plus listed versions
1.9+srconly-21.9+srconly-2+deb9u1
1.9+srconly-2+deb9u2
gif2apng
Ubuntu:Pro:16.04:LTS
before 1.7-3ubuntu0.1~esm1, plus listed versions
1.7-3
1.7-3ubuntu0.1~esm1
gif2apng
Ubuntu:18.04:LTS
before 1.9+srconly-2ubuntu0.1, plus listed versions
1.9+srconly-2
1.9+srconly-2ubuntu0.1
gif2apng
Ubuntu:20.04:LTS
before 1.9+srconly-3ubuntu0.1, plus listed versions
1.9+srconly-31.9+srconly-3build1
1.9+srconly-3ubuntu0.1
gif2apng
Ubuntu:Pro:16.04:LTS
From an advisory covering 3 CVEs
before 1.7-3ubuntu0.1~esm1, plus listed versions
1.7-3
1.7-3ubuntu0.1~esm1
gif2apng
Ubuntu:18.04:LTS
From an advisory covering 3 CVEs
before 1.9+srconly-2ubuntu0.1, plus listed versions
1.9+srconly-2
1.9+srconly-2ubuntu0.1
gif2apng
Ubuntu:20.04:LTS
From an advisory covering 3 CVEs
before 1.9+srconly-3ubuntu0.1, plus listed versions
1.9+srconly-31.9+srconly-3build1
1.9+srconly-3ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-45911 is a high vulnerability (CVSS 7.8) in Gif2apng Project Gif2apng, published December 28, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.90%, the 59th percentile. Fixed in gif2apng 1.9+srconly-3+deb11u1.

References

Show 4 moreShow less
MoveEnter Open