CVE-2021-45943
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile ...
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
- Record
CVE-2021-45943- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
- Record
CVE-2021-45943- Updated
- 2026-11-02
EUVDEUVD-2022-0111 No score
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
- Record
EUVD-2022-0111- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x54c-x29c-rpr5
5.5
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile ...
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
- Record
GHSA-x54c-x29c-rpr5- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
5.5
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
- Record
CVE-2021-45943- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-45943
5.5
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
- Record
DEBIAN-CVE-2021-45943- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVPYSEC-2022-43065
5.5
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
- Record
PYSEC-2022-43065- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-45943
5.5
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
- Record
UBUNTU-CVE-2021-45943- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVBIT-gdal-2021-45943 No score
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).
- Record
BIT-gdal-2021-45943- Updated
- 2026-11-02
OSVMGASA-2022-0137 No score
Updated gdal packages fix security vulnerability
GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment). (CVE-2021-45943)
- Record
MGASA-2022-0137- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gdalBitnami |
3.3.0 up to 3.4.1 | 3.4.1 |
gdalDebian:12 |
before 3.4.1+dfsg-1 | 3.4.1+dfsg-1 |
gdalDebian:13 |
before 3.4.1+dfsg-1 | 3.4.1+dfsg-1 |
gdalDebian:14 |
before 3.4.1+dfsg-1 | 3.4.1+dfsg-1 |
gdalDebian:9 From an advisory covering 2 CVEs |
before 2.1.2+dfsg-5+deb9u1, plus listed versions 2.1.2+dfsg-5 |
2.1.2+dfsg-5+deb9u1 |
gdalDebian:10 From an advisory covering 2 CVEs |
before 2.4.0+dfsg-1+deb10u1, plus listed versions 2.4.0+dfsg-1 |
2.4.0+dfsg-1+deb10u1 |
gdalDebian:11 |
before 3.2.2+dfsg-2+deb11u2, plus listed versions 3.2.2+dfsg-23.2.2+dfsg-2+deb11u1 |
3.2.2+dfsg-2+deb11u2 |
gdalMageia:8 |
before 3.1.3-7.2.mga8 | 3.1.3-7.2.mga8 |
gdalPyPI |
3.3.0 up to 3.4.1, plus listed versions 3.3.13.3.23.3.33.4.0 |
3.4.1 |
gdalUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 1.9.0-3.1ubuntu41.9.0-3.1ubuntu61.10.1+dfsg-21.10.1+dfsg-2build11.10.1+dfsg-3 Show 8 moreShow less1.10.1+dfsg-3build11.10.1+dfsg-3build21.10.1+dfsg-3ubuntu11.10.1+dfsg-3ubuntu21.10.1+dfsg-5ubuntu11.10.1+dfsg-5ubuntu1+esm11.10.1+dfsg-5ubuntu1+esm21.10.1+dfsg-5ubuntu1+esm3 |
None known |
gdalUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.11.2+dfsg-3ubuntu31.11.2+dfsg-3ubuntu41.11.3+dfsg-2build11.11.3+dfsg-2build21.11.3+dfsg-2build3 Show 5 moreShow less1.11.3+dfsg-31.11.3+dfsg-3build11.11.3+dfsg-3build21.11.3+dfsg-3ubuntu0.1~esm11.11.3+dfsg-3ubuntu0.1~esm2 |
None known |
gdalUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 2.2.1+dfsg-2build32.2.1+dfsg-2build52.2.2+dfsg-2build12.2.3+dfsg-12.2.3+dfsg-22.2.3+dfsg-2ubuntu0.1~esm1 |
None known |
gdalUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 2.4.2+dfsg-1build22.4.2+dfsg-1build42.4.2+dfsg-22.4.3+dfsg-13.0.4+dfsg-1 Show 4 moreShow less3.0.4+dfsg-1build13.0.4+dfsg-1build23.0.4+dfsg-1build33.0.4+dfsg-1ubuntu0.1~esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-45943 is a medium vulnerability (CVSS 5.5) in Osgeo Gdal, published December 31, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.54%, the 75th percentile. Fixed in gdal 3.4.1.
References
github.com/google/oss-fuzz-vulns/blob/main/vulns/gdal/OSV-2021-1651.yaml
bugs.chromium.org/p/oss-fuzz/issues/detail?id=41993
github.com/OSGeo/gdal/commit/1ca6a3e5168c200763fa46d8aa7e698d0b757e7e
github.com/OSGeo/gdal/pull/4944
lists.debian.org/debian-lts-announce/2022/01/msg00004.html
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JBPJGXY7IYY65NVJBLP3RONXE7ZBVCNU
Show 17 moreShow less
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P23E4DEHY5FJCR5VJ46I6TO32DT7Y3T4
oracle.com/security-alerts/cpujul2022.html
debian.org/security/2022/dsa-5239
lists.debian.org/debian-lts-announce/2022/09/msg00040.html
security.gentoo.org/glsa/202210-15
nvd.nist.gov/vuln/detail/CVE-2021-45943
lists.fedoraproject.org/archives/list/[email protected]/message/JBPJGXY7IYY65NVJBLP3RONXE7ZBVCNU
lists.fedoraproject.org/archives/list/[email protected]/message/P23E4DEHY5FJCR5VJ46I6TO32DT7Y3T4
github.com/advisories/GHSA-x54c-x29c-rpr5
security-tracker.debian.org/tracker/CVE-2021-45943
advisories.mageia.org/MGASA-2022-0137.html
bugs.mageia.org/show_bug.cgi?id=30256
lists.fedoraproject.org/archives/list/[email protected]/thread/P23E4DEHY5FJCR5VJ46I6TO32DT7Y3T4
ubuntu.com/security/CVE-2021-45943
github.com/OSGeo/gdal/commit/93913a849dc1d217a40dbf9d6e6a3a23c42b61a6
github.com/OSGeo/gdal/commit/9b2bcbc47d1649adc0ab65b801f96f56156cf017
cve.org/CVERecord?id=CVE-2021-45943