CVE-2022-0080
Heap-based Buffer Overflow in mruby/mruby
mruby is vulnerable to Heap-based Buffer Overflow
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List
8.2
Heap-based Buffer Overflow in mruby/mruby
mruby is vulnerable to Heap-based Buffer Overflow
- Record
CVE-2022-0080- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - CVSS 3.0
- 8.2 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-122, CWE-122
- Updated
- 2026-11-02
EUVDEUVD-2022-15300
8.2
mruby is vulnerable to Heap-based Buffer Overflow
- Record
EUVD-2022-15300- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8vcc-hrhr-q8hf
9.8
mruby is vulnerable to Heap-based Buffer Overflow
mruby is vulnerable to Heap-based Buffer Overflow
- Record
GHSA-8vcc-hrhr-q8hf- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-122
- Updated
- 2026-11-02
NVD
9.8
mruby is vulnerable to Heap-based Buffer Overflow
- Record
CVE-2022-0080- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - CVSS 3.0
- 8.2 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-122
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-0080
9.8
mruby is vulnerable to Heap-based Buffer Overflow
- Record
ALPINE-CVE-2022-0080- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
8.2
Heap-based Buffer Overflow in mruby/mruby
mruby is vulnerable to Heap-based Buffer Overflow
- Record
CVE-2022-0080- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-122
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-0080
9.8
mruby is vulnerable to Heap-based Buffer Overflow
- Record
DEBIAN-CVE-2022-0080- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-0080
8.2
mruby is vulnerable to Heap-based Buffer Overflow
- Record
UBUNTU-CVE-2022-0080- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - CVSS 3.0
- 8.2 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11753-1 No score
libmruby3-3.0.0-3.1 on GA media
These are all security issues fixed in the libmruby3-3.0.0-3.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11753-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mrubyAlpine:v3.17 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.18 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.19 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.20 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.21 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.22 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.23 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.24 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyDebian:12 |
before 3.0.0-3 | 3.0.0-3 |
mrubyDebian:13 |
before 3.0.0-3 | 3.0.0-3 |
Show 10 moreShow less
| Package | Affected | Fixed |
|---|---|---|
mrubyDebian:14 |
before 3.0.0-3 | 3.0.0-3 |
mrubyUbuntu:16.04:LTS |
All versions, plus listed versions 1.1.0+20150817+gita1731254-11.1.0+20150906+git1cbbb7e1-11.2.0+20160315+git4f20d58a-1 |
None known |
mrubyUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.0-11.3.0+20170925+git38185028-11.3.0+20171029+git77edafb0-11.4.0-1 |
None known |
mrubyUbuntu:20.04:LTS |
All versions, plus listed versions 2.0.0-1 |
None known |
mrubyUbuntu:22.04:LTS |
All versions, plus listed versions 2.1.2-33.0.0-13.0.0-3 |
None known |
mrubyUbuntu:24.04:LTS |
All versions, plus listed versions 3.2.0-13.2.0-2 |
None known |
mrubyUbuntu:25.10 |
All versions, plus listed versions 3.3.0-1 |
None known |
mrubyUbuntu:26.10 |
All versions, plus listed versions 3.4.0-23.4.0-34.0.0-1 |
None known |
mrubyUbuntu:26.04:LTS |
All versions, plus listed versions 3.3.0-13.4.0-2 |
None known |
mrubyopenSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 3.0.0-3.1 | 3.0.0-3.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | OSV | |
| affected, aliases, references | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0080 is a high vulnerability (CVSS 8.2) in Mruby, published January 2, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.63%, the 76th percentile. Fixed in mruby 3.1.0-r0.
References
huntr.dev/bounties/59a70392-4864-4ce3-8e35-6ac2111d1e2e
github.com/mruby/mruby/commit/28ccc664e5dcd3f9d55173e9afde77c4705a9ab6
nvd.nist.gov/vuln/detail/CVE-2022-0080
github.com/advisories/GHSA-8vcc-hrhr-q8hf
security.alpinelinux.org/vuln/CVE-2022-0080
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0080.json