CVE-2022-0086
Server-Side Request Forgery (SSRF) in transloadit/uppy
uppy is vulnerable to Server-Side Request Forgery (SSRF)
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.2
Server-Side Request Forgery (SSRF) in transloadit/uppy
uppy is vulnerable to Server-Side Request Forgery (SSRF)
- Record
CVE-2022-0086- CVSS 3.0
- 8.2 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-918
- Updated
- 2026-11-02
EUVDEUVD-2022-0738
8.2
uppy is vulnerable to Server-Side Request Forgery (SSRF)
- Record
EUVD-2022-0738- CVSS 3.0
- 8.2 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x8rq-rc7x-5fg5
8.2
uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF)
uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF) via IPv4-mapped IPv6 addresses.
- Record
GHSA-x8rq-rc7x-5fg5- CVSS 3.0
- 8.2 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-918
- Updated
- 2026-11-02
NVD
9.8
uppy is vulnerable to Server-Side Request Forgery (SSRF)
- Record
CVE-2022-0086- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.2 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-918
- Updated
- 2026-11-02
OSV
8.2
Server-Side Request Forgery (SSRF) in transloadit/uppy
uppy is vulnerable to Server-Side Request Forgery (SSRF)
- Record
CVE-2022-0086- CVSS 3.0
- 8.2 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-918
- Updated
- 2026-11-02
OSVGHSA-x8rq-rc7x-5fg5
8.2
uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF)
uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF) via IPv4-mapped IPv6 addresses.
- Record
GHSA-x8rq-rc7x-5fg5- CVSS 3.0
- 8.2 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-918
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
@uppy/companionnpm |
before 3.1.5 | 3.1.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0086 is a high vulnerability (CVSS 8.2) in Transloadit Transloadit/uppy, published January 4, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.25%, the 69th percentile. Fixed in @uppy/companion 3.1.5.
References
huntr.dev/bounties/c1c03ef6-3f18-4976-a9ad-08c251279122
github.com/transloadit/uppy/commit/fc137e30a2a3102eb191141f280d5de20dacdf8f
nvd.nist.gov/vuln/detail/CVE-2022-0086
github.com/transloadit/uppy/pull/3403
github.com/transloadit/uppy/releases/tag/uppy%402.3.3
github.com/advisories/GHSA-x8rq-rc7x-5fg5
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0086.json
github.com/transloadit/uppy