Every CVE Search/ Get API key

CVE-2022-0352

Cross-site Scripting (XSS) - Reflected in janeczku/calibre-web

8.5 HighFix available

CVE-2022-0352 is a high vulnerability (CVSS 8.5) in Janeczku Calibre-web, published January 28, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.85%, the 58th percentile. Fixed in calibreweb 0.6.16.

Cross-site Scripting (XSS) - Reflected in Pypi calibreweb prior to 0.6.16.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.85%Unchanged since Feb 8, 2022
90%50%10%1%

What each source reports

CVE List Score used 8.5

Cross-site Scripting (XSS) - Reflected in janeczku/calibre-web

Cross-site Scripting (XSS) - Reflected in Pypi calibreweb prior to 0.6.16.

Record
CVE-2022-0352
CVSS 3.0
8.5 HighCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-0033 8.5

Cross-site Scripting (XSS) - Reflected in Pypi calibreweb prior to 0.6.16.

Record
EUVD-2022-0033
CVSS 3.0
8.5 HighCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-h56g-v4vp-q9q6 5.3

Cross-site Scripting in calibreweb

calibreweb prior to version 0.6.16 contains a cross-site scripting vulnerability.

Record
GHSA-h56g-v4vp-q9q6
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 6.1

Cross-site Scripting (XSS) - Reflected in Pypi calibreweb prior to 0.6.16.

Record
CVE-2022-0352
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
8.5 HighCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 8.5

Cross-site Scripting (XSS) - Reflected in janeczku/calibre-web

Cross-site Scripting (XSS) - Reflected in Pypi calibreweb prior to 0.6.16.

Record
CVE-2022-0352
CVSS 3.0
8.5 HighCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-h56g-v4vp-q9q6 5.3

Cross-site Scripting in calibreweb

calibreweb prior to version 0.6.16 contains a cross-site scripting vulnerability.

Record
GHSA-h56g-v4vp-q9q6
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2022-18 No score

Cross-site Scripting (XSS) - Reflected in Pypi calibreweb prior to 0.6.16.

Record
PYSEC-2022-18
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
calibreweb
PyPI
before 0.6.16
0.6.16
calibreweb
PyPI
before 0.6.16, plus listed versions
0.6.120.6.130.6.140.6.15
0.6.16

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open