CVE-2022-0372
Cross-site Scripting (XSS) - Stored in crater-invoice/crater
Cross-site Scripting (XSS) - Stored in Packagist bytefury/crater prior to 6.0.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
7.6
Cross-site Scripting (XSS) - Stored in crater-invoice/crater
Cross-site Scripting (XSS) - Stored in Packagist bytefury/crater prior to 6.0.2.
- Record
CVE-2022-0372- CVSS 3.0
- 7.6 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-0489
7.6
Cross-site Scripting (XSS) - Stored in Packagist bytefury/crater prior to 6.0.2.
- Record
EUVD-2022-0489- CVSS 3.0
- 7.6 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6vfw-74wr-3chh
5.4
Cross-site Scripting in Crater Invoice
Crater invoice prior to version 6.0.0 has a cross-site scripting vulnerability.
- Record
GHSA-6vfw-74wr-3chh- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.4
Cross-site Scripting (XSS) - Stored in Packagist bytefury/crater prior to 6.0.2.
- Record
CVE-2022-0372- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 3.0
- 7.6 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
7.6
Cross-site Scripting (XSS) - Stored in crater-invoice/crater
Cross-site Scripting (XSS) - Stored in Packagist bytefury/crater prior to 6.0.2.
- Record
CVE-2022-0372- CVSS 3.0
- 7.6 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-6vfw-74wr-3chh
5.4
Cross-site Scripting in Crater Invoice
Crater invoice prior to version 6.0.0 has a cross-site scripting vulnerability.
- Record
GHSA-6vfw-74wr-3chh- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
bytefury/craterPackagist |
before 6.0.0 | 6.0.0 |
bytefury/craterPackagist |
before 6.0.0, plus listed versions 1.0.01.1.02.0.02.0.12.0.2 Show 18 moreShow less2.1.03.0.03.1.03.1.14.0.04.0.14.0.24.0.34.0.44.1.04.2.05.0.05.0.15.0.25.0.35.0.45.0.55.0.6 |
6.0.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0372 is a high vulnerability (CVSS 7.6) in Crater-invoice Crater-invoice/crater, published January 27, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in bytefury/crater 6.0.0.
References
github.com/crater-invoice/crater/commit/cdc913d16cf624aee852bc9163a7c6ffc8d1da9d
huntr.dev/bounties/563232b9-5a93-4f4d-8389-ed805b262ef1
nvd.nist.gov/vuln/detail/CVE-2022-0372
github.com/crater-invoice/crater/pull/681
github.com/advisories/GHSA-6vfw-74wr-3chh
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0372.json
github.com/crater-invoice/crater