CVE-2022-0414
Improper Validation of Specified Quantity in Input in dolibarr/dolibarr
Improper Validation of Specified Quantity in Input in Packagist dolibarr/dolibarr prior to 16.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.1
Improper Validation of Specified Quantity in Input in dolibarr/dolibarr
Improper Validation of Specified Quantity in Input in Packagist dolibarr/dolibarr prior to 16.0.
- Record
CVE-2022-0414- CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N - Weakness
- CWE-1284
- Updated
- 2026-11-02
EUVDEUVD-2022-0973
4.1
Improper Validation of Specified Quantity in Input in Packagist dolibarr/dolibarr prior to 16.0.
- Record
EUVD-2022-0973- CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f768-8pvq-mm6r
4.3
Dolibarr vulnerable to Improper Validation of Specified Quantity in Input
Dolibarr 14.0.5 and prior versions are vulnerable to Improper Validation of Specified Quantity in Input.
- Record
GHSA-f768-8pvq-mm6r- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-1284
- Updated
- 2026-11-02
NVD
4.3
Improper Validation of Specified Quantity in Input in Packagist dolibarr/dolibarr prior to 16.0.
- Record
CVE-2022-0414- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-1284
- Updated
- 2026-11-02
OSV
4.1
Improper Validation of Specified Quantity in Input in dolibarr/dolibarr
Improper Validation of Specified Quantity in Input in Packagist dolibarr/dolibarr prior to 16.0.
- Record
CVE-2022-0414- CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N - Weakness
- CWE-1284
- Updated
- 2026-11-02
OSVGHSA-f768-8pvq-mm6r
4.3
Dolibarr vulnerable to Improper Validation of Specified Quantity in Input
Dolibarr 14.0.5 and prior versions are vulnerable to Improper Validation of Specified Quantity in Input.
- Record
GHSA-f768-8pvq-mm6r- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-1284
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-0414
4.3
Improper Validation of Specified Quantity in Input in Packagist dolibarr/dolibarr prior to 16.0.
- Record
UBUNTU-CVE-2022-0414- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N - Updated
- 2026-11-02
OSVBIT-dolibarr-2022-0414 No score
Improper Validation of Specified Quantity in Input in dolibarr/dolibarr
Improper Validation of Specified Quantity in Input in Packagist dolibarr/dolibarr prior to 16.0.
- Record
BIT-dolibarr-2022-0414- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dolibarr/dolibarrPackagist |
through 14.0.5 | 15.0 |
dolibarrBitnami |
before 16.0.0 | 16.0.0 |
dolibarr/dolibarrPackagist |
before 15.0, plus listed versions 10.0.010.0.110.0.210.0.310.0.4 Show 45 moreShow less10.0.510.0.610.0.711.0.011.0.111.0.211.0.311.0.411.0.512.0.012.0.112.0.212.0.312.0.412.0.513.0.013.0.113.0.213.0.313.0.413.0.514.0.014.0.114.0.214.0.314.0.414.0.53.6.03.6.0-beta3.6.13.6.23.6.33.6.43.6.53.6.63.7.03.7.13.7.23.7.33.7.43.8.03.8.0-beta3.8.13.8.23.8.3 |
15.0 |
dolibarrUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 3.5.5+dfsg1-23.5.7+dfsg1-13.5.8+dfsg1-13.5.8+dfsg1-1ubuntu13.5.8+dfsg1-1ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0414 is a medium vulnerability (CVSS 4.1) in Dolibarr Dolibarr/dolibarr, published January 31, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in dolibarr/dolibarr 15.0.
References
huntr.dev/bounties/76f3b405-9f5d-44b1-8434-b52b56ee395f
github.com/dolibarr/dolibarr/commit/37fb02ee760cfff18c795ba468da1ba1c53f4684
nvd.nist.gov/vuln/detail/CVE-2022-0414
github.com/advisories/GHSA-f768-8pvq-mm6r
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0414.json
github.com/dolibarr/dolibarr
ubuntu.com/security/CVE-2022-0414
cve.org/CVERecord?id=CVE-2022-0414
Left out here: 58 versions. The JSON record has them.