Every CVE Search/ Get API key

CVE-2022-0430

Exposure of Sensitive Information to an Unauthorized Actor in httpie/httpie

2.4 LowFix available

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

1.29%Up 0.4 points since Mar 16, 2022
90%50%10%1%

What each source reports

CVE List Score used 2.4

Exposure of Sensitive Information to an Unauthorized Actor in httpie/httpie

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.

Record
CVE-2022-0430
CVSS 3.0
2.4 LowCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
EUVDEUVD-2022-0120 2.4

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.

Record
EUVD-2022-0120
CVSS 3.0
2.4 LowCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-6pc9-xqrg-wfqw 4.8

Exposure of Sensitive information in httpie

httpie is a modern, user-friendly command-line HTTP client for the API era. Prior to version 3.1.0, all cookies saved to session storage are supercookies. At this time, there is no known workaround. Users are recommended to update to version 3.1.0.

Record
GHSA-6pc9-xqrg-wfqw
CVSS 4.0
4.8 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
2.4 LowCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
NVD 5.3

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.

Record
CVE-2022-0430
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
CVSS 3.0
2.4 LowCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 2.4

Exposure of Sensitive Information to an Unauthorized Actor in httpie/httpie

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.

Record
CVE-2022-0430
CVSS 3.0
2.4 LowCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSVDEBIAN-CVE-2022-0430 5.3

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.

Record
DEBIAN-CVE-2022-0430
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-03
OSVGHSA-6pc9-xqrg-wfqw 4.8

Exposure of Sensitive information in httpie

httpie is a modern, user-friendly command-line HTTP client for the API era. Prior to version 3.1.0, all cookies saved to session storage are supercookies. At this time, there is no known workaround. Users are recommended to update to version 3.1.0.

Record
GHSA-6pc9-xqrg-wfqw
CVSS 4.0
4.8 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
2.4 LowCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSVUBUNTU-CVE-2022-0430 5.3

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.

Record
UBUNTU-CVE-2022-0430
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
CVSS 3.0
2.4 LowCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVPYSEC-2022-167 No score

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.

Record
PYSEC-2022-167
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
httpie
PyPI
before 3.1.0
3.1.0
httpie
Debian:12
before 3.2.1-1
3.2.1-1
httpie
Debian:13
before 3.2.1-1
3.2.1-1
httpie
Debian:14
before 3.2.1-1
3.2.1-1
httpie
PyPI
before 3.1.0, plus listed versions
0.10.1.10.1.20.1.30.1.4
Show 44 moreShow less
0.1.50.1.60.2.00.2.10.2.20.2.30.2.40.2.4dev0.2.50.2.60.2.70.3.00.3.10.4.00.4.10.5.00.5.10.6.00.7.00.7.20.8.00.9.00.9.10.9.20.9.30.9.40.9.50.9.60.9.70.9.80.9.91.0.01.0.21.0.32.0.02.1.02.2.02.3.02.4.02.5.02.6.03.0.03.0.13.0.2
3.1.0
httpie
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
0.3.1-10.7.1-0.10.8.0-10.8.0-1+deb8u1build0.14.04.1~esm1
None known
httpie
Ubuntu:16.04:LTS
All versions, plus listed versions
0.9.2-0.10.9.2-1
None known
httpie
Ubuntu:18.04:LTS
All versions, plus listed versions
0.9.8-2
None known
httpie
Ubuntu:20.04:LTS
All versions, plus listed versions
0.9.8-21.0.3-2
None known
httpie
Ubuntu:22.04:LTS
All versions, plus listed versions
2.4.0-12.6.0-1
None known
Show 4 moreShow less
Affected packages
PackageAffectedFixed
httpie
Ubuntu:24.04:LTS
All versions, plus listed versions
3.2.1-13.2.1-23.2.2-1
None known
httpie
Ubuntu:25.10
All versions, plus listed versions
3.2.4-3
None known
httpie
Ubuntu:26.10
All versions, plus listed versions
3.2.4-4
None known
httpie
Ubuntu:26.04:LTS
All versions, plus listed versions
3.2.4-33.2.4-4
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0430 is a low vulnerability (CVSS 2.4) in Httpie, published March 15, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.29%, the 70th percentile. Fixed in httpie 3.1.0.

References

Show 4 moreShow less
MoveEnter Open