CVE-2022-0501
Cross-site Scripting (XSS) - Reflected in ptrofimov/beanstalk_console
Cross-site Scripting (XSS) - Reflected in Packagist ptrofimov/beanstalk_console prior to 1.7.12.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
8.6
Cross-site Scripting (XSS) - Reflected in ptrofimov/beanstalk_console
Cross-site Scripting (XSS) - Reflected in Packagist ptrofimov/beanstalk_console prior to 1.7.12.
- Record
CVE-2022-0501- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-1017
8.6
Cross-site Scripting (XSS) - Reflected in Packagist ptrofimov/beanstalk_console prior to 1.7.12.
- Record
EUVD-2022-1017- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gj85-pvp5-mvf9
6.1
Cross-site Scripting in Beanstalk console
Beanstalk console prior to version 1.7.12 is vulnerable to cross-site scripting.
- Record
GHSA-gj85-pvp5-mvf9- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
6.1
Cross-site Scripting (XSS) - Reflected in Packagist ptrofimov/beanstalk_console prior to 1.7.12.
- Record
CVE-2022-0501- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 3.0
- 8.6 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
8.6
Cross-site Scripting (XSS) - Reflected in ptrofimov/beanstalk_console
Cross-site Scripting (XSS) - Reflected in Packagist ptrofimov/beanstalk_console prior to 1.7.12.
- Record
CVE-2022-0501- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-gj85-pvp5-mvf9
6.1
Cross-site Scripting in Beanstalk console
Beanstalk console prior to version 1.7.12 is vulnerable to cross-site scripting.
- Record
GHSA-gj85-pvp5-mvf9- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ptrofimov/beanstalk_consolePackagist |
before 1.7.12 | 1.7.12 |
ptrofimov/beanstalk_consolePackagist |
before 1.7.12, plus listed versions 1.2.11.2.21.31.3.11.3.2 Show 20 moreShow less1.41.4.11.51.5.11.5.21.5.31.61.6.11.71.7.11.7.101.7.111.7.21.7.31.7.41.7.51.7.61.7.71.7.81.7.9 |
1.7.12 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0501 is a high vulnerability (CVSS 8.6) in Beanstalk Console Project Console, published February 5, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 59th percentile. Fixed in ptrofimov/beanstalk_console 1.7.12.
References
huntr.dev/bounties/9af1c35e-3f74-4c93-a241-e8be01335ec7
github.com/ptrofimov/beanstalk_console/commit/e351c8260ec1d3718d9e475ee57c7e12c47f19da
nvd.nist.gov/vuln/detail/CVE-2022-0501
github.com/advisories/GHSA-gj85-pvp5-mvf9
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0501.json
github.com/ptrofimov/beanstalk_console