CVE-2022-0524
Business Logic Errors in publify/publify
Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Business Logic Errors in publify/publify
Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.
- Record
CVE-2022-0524- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-840
- Updated
- 2026-11-02
EUVDEUVD-2022-1245
6.5
Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.
- Record
EUVD-2022-1245- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x3rq-r3cm-5vc4
7.5
Publify Business Logic Errors
Publify (formerly known as Typo) prior to version 9.2.7 is vulnerable to business logic errors.
- Record
GHSA-x3rq-r3cm-5vc4- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-841
- Updated
- 2026-11-02
NVD
7.5
Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.
- Record
CVE-2022-0524- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-840
- Updated
- 2026-11-02
OSV
6.5
Business Logic Errors in publify/publify
Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.
- Record
CVE-2022-0524- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-840
- Updated
- 2026-11-02
OSVGHSA-x3rq-r3cm-5vc4
7.5
Publify Business Logic Errors
Publify (formerly known as Typo) prior to version 9.2.7 is vulnerable to business logic errors.
- Record
GHSA-x3rq-r3cm-5vc4- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-841
- Updated
- 2026-11-02
OSVBIT-publify-2022-0524 No score
Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.
- Record
BIT-publify-2022-0524- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
publify_coreRubyGems |
before 9.2.7 | 9.2.7 |
publifyBitnami |
before 9.2.7 | 9.2.7 |
publify_coreRubyGems |
before 9.2.7, plus listed versions 9.0.09.0.0.pre19.0.0.pre29.0.0.pre39.0.0.pre4 Show 11 moreShow less9.0.0.pre59.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.49.2.59.2.6 |
9.2.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0524 is a medium vulnerability (CVSS 6.5) in Publify Publify/publify, published February 8, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in publify_core 9.2.7.
References
huntr.dev/bounties/bfffae58-b3cd-4e0e-b1f2-3db387a22c3d
github.com/publify/publify/commit/16fceecadbe80ab0ef846b62a12dc7bfff10b8c5
nvd.nist.gov/vuln/detail/CVE-2022-0524
github.com/publify/publify/pull/1044
github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2022-0524.yml
github.com/advisories/GHSA-x3rq-r3cm-5vc4
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0524.json
github.com/publify/publify