CVE-2022-0538
DoS vulnerability in bundled XStream library in Jenkins Core
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.
- Record
CVE-2022-0538- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-502
- Updated
- 2026-11-02
CVE List No score
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.
- Record
CVE-2022-0538- Updated
- 2026-11-02
EUVDEUVD-2022-0776 No score
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.
- Record
EUVD-2022-0776- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-34wx-x2w9-vqm3
6.5
DoS vulnerability in bundled XStream library in Jenkins Core
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier is affected by the XStream library’s vulnerability CVE-2021-43859. This library is used by Jenkins to serialize and deserialize various XML files, like global and job config.xml, build.xml, and numerous others.
This allows attackers able to submit crafted XML files to Jenkins to be parsed as configuration, e.g. through the POST config.xml API, to cause a denial of service (DoS).
- Record
GHSA-34wx-x2w9-vqm3- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-0538
7.5
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.
- Record
ALPINE-CVE-2022-0538- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
OSV
7.5
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.
- Record
CVE-2022-0538- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-34wx-x2w9-vqm3
6.5
DoS vulnerability in bundled XStream library in Jenkins Core
Jenkins 2.333 and earlier, LTS 2.319.2 and earlier is affected by the XStream library’s vulnerability CVE-2021-43859. This library is used by Jenkins to serialize and deserialize various XML files, like global and job config.xml, build.xml, and numerous others.
This allows attackers able to submit crafted XML files to Jenkins to be parsed as configuration, e.g. through the POST config.xml API, to cause a denial of service (DoS).
- Record
GHSA-34wx-x2w9-vqm3- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
OSVBIT-jenkins-2022-0538 No score
Jenkins LTS 2.319.2 and earlier defines custom XStream converters that have not been updated to apply the protections for the vulnerability CVE-2021-43859 and allow unconstrained resource usage.
- Record
BIT-jenkins-2022-0538- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jenkins-ci.main:jenkins-coreMaven |
2.320 up to 2.334 | 2.334 |
org.jenkins-ci.main:jenkins-coreMaven |
before 2.319.3 | 2.319.3 |
jenkinsAlpine:v3.12 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.13 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.14 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.15 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.16 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.17 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.18 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.19 |
before 2.319.3-r0 | 2.319.3-r0 |
Show 8 moreShow less
| Package | Affected | Fixed |
|---|---|---|
jenkinsAlpine:v3.20 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.21 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.22 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.23 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsAlpine:v3.24 |
before 2.319.3-r0 | 2.319.3-r0 |
jenkinsBitnami |
before 2.334.0 | 2.334.0 |
org.jenkins-ci.main:jenkins-coreMaven |
2.320 up to 2.334, plus listed versions 2.3212.3222.3232.3242.325 Show 12 moreShow less2.3262.3272.3282.3292.3302.3312.3322.332.12.332.22.332.32.332.42.333 |
2.334 |
org.jenkins-ci.main:jenkins-coreMaven |
before 2.319.3, plus listed versions 1.3961.3971.3981.3991.400 Show 45 moreShow less1.4011.4031.4041.4051.4061.4071.4081.4091.409.11.409.21.409.31.4101.4111.4121.4131.4141.4151.4161.4171.4181.4191.4201.4211.4221.4231.4241.424.11.424.21.424.31.424.41.424.51.424.61.4251.4261.4271.4281.4291.4301.4311.4321.4331.4341.4351.4361.437 |
2.319.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0538 is a high vulnerability (CVSS 7.5) in Jenkins, published February 9, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.90%, the 90th percentile. Fixed in org.jenkins-ci.main:jenkins-core 2.334.
References
Left out here: 676 versions. The JSON record has them.