CVE-2022-0539
Cross-site Scripting (XSS) - Stored in ptrofimov/beanstalk_console
Cross-site Scripting (XSS) - Stored in Packagist ptrofimov/beanstalk_console prior to 1.7.14.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
6.3
Cross-site Scripting (XSS) - Stored in ptrofimov/beanstalk_console
Cross-site Scripting (XSS) - Stored in Packagist ptrofimov/beanstalk_console prior to 1.7.14.
- Record
CVE-2022-0539- CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-0759
6.3
Cross-site Scripting (XSS) - Stored in Packagist ptrofimov/beanstalk_console prior to 1.7.14.
- Record
EUVD-2022-0759- CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2cjf-w7c4-fhf6
6.3
Cross-site Scripting in Beanstalk console
Beanstalk console (ptrofimov/beanstalk_console) prior to 1.7.14 is vulnerable to cross-site scripting.
- Record
GHSA-2cjf-w7c4-fhf6- CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.4
Cross-site Scripting (XSS) - Stored in Packagist ptrofimov/beanstalk_console prior to 1.7.14.
- Record
CVE-2022-0539- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.3
Cross-site Scripting (XSS) - Stored in ptrofimov/beanstalk_console
Cross-site Scripting (XSS) - Stored in Packagist ptrofimov/beanstalk_console prior to 1.7.14.
- Record
CVE-2022-0539- CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-2cjf-w7c4-fhf6
6.3
Cross-site Scripting in Beanstalk console
Beanstalk console (ptrofimov/beanstalk_console) prior to 1.7.14 is vulnerable to cross-site scripting.
- Record
GHSA-2cjf-w7c4-fhf6- CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ptrofimov/beanstalk_consolePackagist |
before 1.7.14 | 1.7.14 |
ptrofimov/beanstalk_consolePackagist |
before 1.7.14, plus listed versions 1.2.11.2.21.31.3.11.3.2 Show 22 moreShow less1.41.4.11.51.5.11.5.21.5.31.61.6.11.71.7.11.7.101.7.111.7.121.7.131.7.21.7.31.7.41.7.51.7.61.7.71.7.81.7.9 |
1.7.14 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0539 is a medium vulnerability (CVSS 6.3) in Beanstalk Console Project Console, published February 9, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.64%, the 50th percentile. Fixed in ptrofimov/beanstalk_console 1.7.14.
References
huntr.dev/bounties/5f41b182-dda2-4c6f-9668-2a9afaed53af
github.com/ptrofimov/beanstalk_console/commit/5aea5f912f6e6d19dedb1fdfc25a29a2e1fc1694
nvd.nist.gov/vuln/detail/CVE-2022-0539
github.com/advisories/GHSA-2cjf-w7c4-fhf6
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0539.json
github.com/ptrofimov/beanstalk_console