Every CVE Search/ Get API key

CVE-2022-0544

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly...

5.5 MediumFix available

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.15%Up 0.3 points since Feb 25, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.

Record
CVE-2022-0544
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:P/I:N/A:N
Weakness
CWE-191
Updated
2026-11-02
CVE List No score

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.

Record
CVE-2022-0544
Weakness
CWE-191
Updated
2026-11-02
EUVDEUVD-2022-15666 No score

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.

Record
EUVD-2022-15666
Updated
2026-11-03
GitHub AdvisoriesGHSA-vcg5-3355-6jf2 5.5

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly...

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.

Record
GHSA-vcg5-3355-6jf2
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Weakness
CWE-191
Updated
2026-11-02
OSVDEBIAN-CVE-2022-0544 5.5

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.

Record
DEBIAN-CVE-2022-0544
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Updated
2026-11-03
OSVUBUNTU-CVE-2022-0544 5.5

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.

Record
UBUNTU-CVE-2022-0544
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Updated
2026-11-02
Show 6 moreShow less
OSV No score

An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.

Record
CVE-2022-0544
Weakness
CWE-191
Updated
2026-11-02
OSVopenSUSE-SU-2024:11859-1 No score

blender-3.0.1-2.1 on GA media

These are all security issues fixed in the blender-3.0.1-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11859-1
Updated
2026-11-02
OSVopenSUSE-SU-2025:15755-1 No score

blender-4.5-4.5.4-1.1 on GA media

These are all security issues fixed in the blender-4.5-4.5.4-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15755-1
Updated
2026-11-02
OSVopenSUSE-SU-2025:15756-1 No score

blender-5.0-5.0.0-1.1 on GA media

These are all security issues fixed in the blender-5.0-5.0.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15756-1
Updated
2026-11-02
OSVopenSUSE-SU-2026:10560-1 No score

blender-5.1-5.1.1-1.1 on GA media

These are all security issues fixed in the blender-5.1-5.1.1-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:10560-1
Updated
2026-11-02
OSVopenSUSE-SU-2026:11288-1 No score

blender-5.2-5.2.0-1.1 on GA media

These are all security issues fixed in the blender-5.2-5.2.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:11288-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
blender
Debian:12
before 3.1.2+dfsg-1
3.1.2+dfsg-1
blender
Debian:13
before 3.1.2+dfsg-1
3.1.2+dfsg-1
blender
Debian:9
From an advisory covering 3 CVEs
before 2.79.b+dfsg0-1~deb9u2, plus listed versions
2.78.a+dfsg0-42.78.c+dfsg0-12.78.c+dfsg0-22.79+dfsg0-12.79+dfsg0-2
Show 4 moreShow less
2.79+dfsg0-32.79.a+dfsg0-12.79.a+dfsg0-22.79.b+dfsg0-1~deb9u1
2.79.b+dfsg0-1~deb9u2
blender
Debian:10
From an advisory covering 3 CVEs
before 2.79.b+dfsg0-7+deb10u1, plus listed versions
2.79.b+dfsg0-7
2.79.b+dfsg0-7+deb10u1
blender
Debian:11
From an advisory covering 3 CVEs
before 2.83.5+dfsg-5+deb11u1, plus listed versions
2.83.5+dfsg-5
2.83.5+dfsg-5+deb11u1
blender
Ubuntu:16.04:LTS
All versions, plus listed versions
2.74+dfsg0-4build22.75.a+dfsg0-2ubuntu22.75.a+dfsg0-2ubuntu32.76.b+dfsg0-32.76.b+dfsg0-3build1
None known
blender
Ubuntu:18.04:LTS
All versions, plus listed versions
2.78.c+dfsg0-2build12.79+dfsg0-2build12.79+dfsg0-32.79+dfsg0-3build12.79.b+dfsg0-12.79.b+dfsg0-1ubuntu1.18.04.1
None known
blender
Ubuntu:20.04:LTS
All versions, plus listed versions
2.80+dfsg-32.80+dfsg-3build12.80+dfsg-42.81.a+dfsg-5build32.82+dfsg-12.82+dfsg-1build12.82.a+dfsg-1
None known
blender
Ubuntu:22.04:LTS
All versions, plus listed versions
2.93.3+dfsg-32.93.5+dfsg-12.93.5+dfsg-1build13.0.1+dfsg-7
None known
blender
Ubuntu:24.04:LTS
All versions, plus listed versions
3.6.2+dfsg-2ubuntu13.6.2+dfsg-2ubuntu24.0.2+dfsg-1ubuntu14.0.2+dfsg-1ubuntu24.0.2+dfsg-1ubuntu44.0.2+dfsg-1ubuntu64.0.2+dfsg-1ubuntu74.0.2+dfsg-1ubuntu8
None known
Show 8 moreShow less
Affected packages
PackageAffectedFixed
blender
Ubuntu:25.10
All versions, plus listed versions
4.3.2+dfsg-24.3.2+dfsg-2ubuntu14.3.2+dfsg-2ubuntu2
None known
blender
Ubuntu:26.10
All versions, plus listed versions
5.0.1+dfsg-1ubuntu15.0.1+dfsg-1ubuntu35.0.1+dfsg-3build15.0.1+dfsg-5
None known
blender
Ubuntu:26.04:LTS
All versions, plus listed versions
4.3.2+dfsg-2ubuntu25.0.1+dfsg-1ubuntu1
None known
blender
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 3.0.1-2.1
3.0.1-2.1
blender-4.5
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 4.5.4-1.1
4.5.4-1.1
blender-5.0
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 5.0.0-1.1
5.0.0-1.1
blender-5.1
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 5.1.1-1.1
5.1.1-1.1
blender-5.2
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 5.2.0-1.1
5.2.0-1.1

History

History
RecordedChangedSources
affected, factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0544 is a medium vulnerability (CVSS 5.5) in Blender, published February 24, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 67th percentile. Fixed in blender 3.1.2+dfsg-1.

References

Show 9 moreShow less
MoveEnter Open