Every CVE Search/ Get API key

CVE-2022-0558

Cross-site Scripting (XSS) - Stored in microweber/microweber

9.8 CriticalFix available

Cross-site Scripting (XSS) - Stored in Packagist microweber/microweber prior to 1.2.11.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.90%Unchanged since Feb 11, 2022
90%50%10%1%

What each source reports

CVE List Score used 9.8

Cross-site Scripting (XSS) - Stored in microweber/microweber

Cross-site Scripting (XSS) - Stored in Packagist microweber/microweber prior to 1.2.11.

Record
CVE-2022-0558
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-1231 9.8

Cross-site Scripting (XSS) - Stored in Packagist microweber/microweber prior to 1.2.11.

Record
EUVD-2022-1231
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-wmj9-xh24-j4gx 5.4

Cross-site Scripting in microweber

microweber prior to version 1.2.11 is vulnerable to cross-site scripting.

Record
GHSA-wmj9-xh24-j4gx
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

Cross-site Scripting (XSS) - Stored in Packagist microweber/microweber prior to 1.2.11.

Record
CVE-2022-0558
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 9.8

Cross-site Scripting (XSS) - Stored in microweber/microweber

Cross-site Scripting (XSS) - Stored in Packagist microweber/microweber prior to 1.2.11.

Record
CVE-2022-0558
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-wmj9-xh24-j4gx 5.4

Cross-site Scripting in microweber

microweber prior to version 1.2.11 is vulnerable to cross-site scripting.

Record
GHSA-wmj9-xh24-j4gx
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
microweber/microweber
Packagist
before 1.2.11
1.2.11
microweber/microweber
Packagist
before 1.2.11, plus listed versions
0.9.3460.930.9310.9340.951
Show 14 moreShow less
1.0.31.0.41.0.51.0.61.0.71.1v1.2.10v1.2.3v1.2.4v1.2.5v1.2.6v1.2.7v1.2.8v1.2.9
1.2.11

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0558 is a critical vulnerability (CVSS 9.8) in Microweber, published February 10, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.90%, the 59th percentile. Fixed in microweber/microweber 1.2.11.

References

MoveEnter Open