CVE-2022-0578
Code Injection in publify/publify
Code Injection in GitHub repository publify/publify prior to 9.2.8.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.3
Code Injection in publify/publify
Code Injection in GitHub repository publify/publify prior to 9.2.8.
- Record
CVE-2022-0578- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2022-5520
5.3
Code Injection in GitHub repository publify/publify prior to 9.2.8.
- Record
EUVD-2022-5520- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w78q-4w34-jrjx
6.5
Publify vulnerable to code injection
Code Injection in GitHub repository publify/publify prior to 9.2.8.
- Record
GHSA-w78q-4w34-jrjx- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
NVD
6.5
Code Injection in GitHub repository publify/publify prior to 9.2.8.
- Record
CVE-2022-0578- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:P/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
5.3
Code Injection in publify/publify
Code Injection in GitHub repository publify/publify prior to 9.2.8.
- Record
CVE-2022-0578- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVGHSA-w78q-4w34-jrjx
6.5
Publify vulnerable to code injection
Code Injection in GitHub repository publify/publify prior to 9.2.8.
- Record
GHSA-w78q-4w34-jrjx- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVBIT-publify-2022-0578 No score
Code Injection in GitHub repository publify/publify prior to 9.2.8.
- Record
BIT-publify-2022-0578- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
publify_coreRubyGems |
before 9.2.8 | 9.2.8 |
publifyBitnami |
before 9.2.8 | 9.2.8 |
publify_coreRubyGems |
before 9.2.8, plus listed versions 9.0.09.0.0.pre19.0.0.pre29.0.0.pre39.0.0.pre4 Show 12 moreShow less9.0.0.pre59.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.49.2.59.2.69.2.7 |
9.2.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0578 is a medium vulnerability (CVSS 5.3) in Publify Publify/publify, published May 16, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.91%, the 60th percentile. Fixed in publify_core 9.2.8.
References
huntr.dev/bounties/02c81928-eb47-476f-8000-e93dc796dbcc
github.com/publify/publify/commit/b50df050c593cc532b2c516792989bcfce2d73f7
nvd.nist.gov/vuln/detail/CVE-2022-0578
github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2022-0578.yml
github.com/advisories/GHSA-w78q-4w34-jrjx
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0578.json
github.com/publify/publify