CVE-2022-0580
Incorrect Authorization in librenms/librenms
Incorrect Authorization in Packagist librenms/librenms prior to 22.2.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.1
Incorrect Authorization in librenms/librenms
Incorrect Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
CVE-2022-0580- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
EUVDEUVD-2022-0774
7.1
Incorrect Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
EUVD-2022-0774- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-33wf-4crm-2322
7.1
Improper Access Control in librenms
Improper Access Control in Packagist librenms/librenms prior to 22.2.0.
- Record
GHSA-33wf-4crm-2322- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-284, CWE-863
- Updated
- 2026-11-02
NVD
7.1
Incorrect Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
CVE-2022-0580- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-863
- Updated
- 2026-11-02
OSV
7.1
Incorrect Authorization in librenms/librenms
Incorrect Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
CVE-2022-0580- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
OSVGHSA-33wf-4crm-2322
7.1
Improper Access Control in librenms
Improper Access Control in Packagist librenms/librenms prior to 22.2.0.
- Record
GHSA-33wf-4crm-2322- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-284, CWE-863
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
librenms/librenmsPackagist |
before 22.2.0 | 22.2.0 |
librenms/librenmsPackagist |
before 22.2.0, plus listed versions 1.191.201.20.11.211.22 Show 45 moreShow less1.22.011.231.241.251.261.271.281.291.301.30.011.311.31.011.31.021.31.031.321.32.011.331.33.011.341.351.361.36.011.371.381.391.401.411.421.42.011.431.441.451.461.471.481.48.11.491.501.50.11.511.521.531.53.11.541.55 |
22.2.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0580 is a high vulnerability (CVSS 7.1) in Librenms, published February 14, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 68th percentile. Fixed in librenms/librenms 22.2.0.
References
huntr.dev/bounties/2494106c-7703-4558-bb1f-1eae59d264e3
github.com/librenms/librenms/commit/95970af78e4c899744a715766d744deef8c505f7
notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
nvd.nist.gov/vuln/detail/CVE-2022-0580
github.com/advisories/GHSA-33wf-4crm-2322
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0580.json
github.com/librenms/librenms
Left out here: 39 versions. The JSON record has them.