CVE-2022-0587
Improper Authorization in librenms/librenms
Improper Authorization in Packagist librenms/librenms prior to 22.2.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.1
Improper Authorization in librenms/librenms
Improper Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
CVE-2022-0587- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2022-1132
7.1
Improper Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
EUVD-2022-1132- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-ppfm-rj6p-38q6
7.1
Improper Authorization in librenms
Improper Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
GHSA-ppfm-rj6p-38q6- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
NVD
6.5
Improper Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
CVE-2022-0587- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSV
7.1
Improper Authorization in librenms/librenms
Improper Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
CVE-2022-0587- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVGHSA-ppfm-rj6p-38q6
7.1
Improper Authorization in librenms
Improper Authorization in Packagist librenms/librenms prior to 22.2.0.
- Record
GHSA-ppfm-rj6p-38q6- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
librenms/librenmsPackagist |
before 22.2.0 | 22.2.0 |
librenms/librenmsPackagist |
before 22.2.0, plus listed versions 1.191.201.20.11.211.22 Show 45 moreShow less1.22.011.231.241.251.261.271.281.291.301.30.011.311.31.011.31.021.31.031.321.32.011.331.33.011.341.351.361.36.011.371.381.391.401.411.421.42.011.431.441.451.461.471.481.48.11.491.501.50.11.511.521.531.53.11.541.55 |
22.2.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0587 is a high vulnerability (CVSS 7.1) in Librenms, published February 15, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in librenms/librenms 22.2.0.
References
github.com/librenms/librenms/commit/95970af78e4c899744a715766d744deef8c505f7
huntr.dev/bounties/0c7c9ecd-33ac-4865-b05b-447ced735469
notes.netbytesec.com/2022/02/multiple-vulnerabilities-in-librenms.html
nvd.nist.gov/vuln/detail/CVE-2022-0587
github.com/advisories/GHSA-ppfm-rj6p-38q6
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0587.json
github.com/librenms/librenms
Left out here: 39 versions. The JSON record has them.