Every CVE Search/ Get API key

CVE-2022-0596

Improper Validation of Specified Quantity in Input in microweber/microweber

5.4 MediumFix available

Improper Validation of Specified Quantity in Input in Packagist microweber/microweber prior to 1.2.11.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.62%Down 0.3 points since Feb 16, 2022
90%50%10%1%

What each source reports

CVE List Score used 5.4

Improper Validation of Specified Quantity in Input in microweber/microweber

Improper Validation of Specified Quantity in Input in Packagist microweber/microweber prior to 1.2.11.

Record
CVE-2022-0596
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-1284
Updated
2026-11-02
EUVDEUVD-2022-1212 5.4

Improper Validation of Specified Quantity in Input in Packagist microweber/microweber prior to 1.2.11.

Record
EUVD-2022-1212
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-vpq7-m4qm-p2gp 4.3

Microweber vulnerable to Improper Validation of Specified Quantity in Input

Microweber prior to version 1.2.11 can have a negative product amount. This could allow an attacker to manipulate the total value and get products for free.

Record
GHSA-vpq7-m4qm-p2gp
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-1284
Updated
2026-11-02
NVD 4.3

Improper Validation of Specified Quantity in Input in Packagist microweber/microweber prior to 1.2.11.

Record
CVE-2022-0596
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-1284
Updated
2026-11-02
OSV 5.4

Improper Validation of Specified Quantity in Input in microweber/microweber

Improper Validation of Specified Quantity in Input in Packagist microweber/microweber prior to 1.2.11.

Record
CVE-2022-0596
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-1284
Updated
2026-11-02
OSVGHSA-vpq7-m4qm-p2gp 4.3

Microweber vulnerable to Improper Validation of Specified Quantity in Input

Microweber prior to version 1.2.11 can have a negative product amount. This could allow an attacker to manipulate the total value and get products for free.

Record
GHSA-vpq7-m4qm-p2gp
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-1284
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
microweber/microweber
Packagist
before 1.2.11
1.2.11
microweber/microweber
Packagist
before 1.2.11, plus listed versions
0.9.3460.930.9310.9340.951
Show 14 moreShow less
1.0.31.0.41.0.51.0.61.0.71.1v1.2.10v1.2.3v1.2.4v1.2.5v1.2.6v1.2.7v1.2.8v1.2.9
1.2.11

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0596 is a medium vulnerability (CVSS 5.4) in Microweber, published February 15, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.62%, the 49th percentile. Fixed in microweber/microweber 1.2.11.

References

MoveEnter Open