Every CVE Search/ Get API key

CVE-2022-0602

Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter

7.4 HighFix available

Cross-site Scripting (XSS) - DOM in GitHub repository tastyigniter/tastyigniter prior to 3.3.0.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.72%Down 0.2 points since Apr 9, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.4

Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter

Cross-site Scripting (XSS) - DOM in GitHub repository tastyigniter/tastyigniter prior to 3.3.0.

Record
CVE-2022-0602
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-1708 7.4

Cross-site Scripting (XSS) - DOM in GitHub repository tastyigniter/tastyigniter prior to 3.3.0.

Record
EUVD-2022-1708
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-cjw5-f2x5-r4q5 7.4

Cross-site Scripting in TastyIgniter

TastyIgniter prior to version 3.3.0 is vulnerable to Document Object Model (DOM) based Cross-site Scripting (XSS).

Record
GHSA-cjw5-f2x5-r4q5
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

Cross-site Scripting (XSS) - DOM in GitHub repository tastyigniter/tastyigniter prior to 3.3.0.

Record
CVE-2022-0602
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 7.4

Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter

Cross-site Scripting (XSS) - DOM in GitHub repository tastyigniter/tastyigniter prior to 3.3.0.

Record
CVE-2022-0602
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-cjw5-f2x5-r4q5 7.4

Cross-site Scripting in TastyIgniter

TastyIgniter prior to version 3.3.0 is vulnerable to Document Object Model (DOM) based Cross-site Scripting (XSS).

Record
GHSA-cjw5-f2x5-r4q5
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
tastyigniter/tastyigniter
Packagist
before 3.3.0
3.3.0
tastyigniter/tastyigniter
Packagist
before 3.3.0, plus listed versions
2.1.02.1.0-rc.12.1.0-rc.22.1.1v0.5.0
Show 45 moreShow less
v1.0.0v1.1.0v1.2.0v1.2.1v1.3.0v1.3.1v1.4.0v1.4.1v3.0.4v3.0.4-betav3.0.4-beta.10v3.0.4-beta.11v3.0.4-beta.12v3.0.4-beta.13v3.0.4-beta.14v3.0.4-beta.15v3.0.4-beta.16v3.0.4-beta.17v3.0.4-beta.18v3.0.4-beta.19v3.0.4-beta.2v3.0.4-beta.20v3.0.4-beta.20.1v3.0.4-beta.21v3.0.4-beta.22v3.0.4-beta.22.1v3.0.4-beta.22.2v3.0.4-beta.22.3v3.0.4-beta.22.4v3.0.4-beta.23v3.0.4-beta.23.1v3.0.4-beta.23.2v3.0.4-beta.24v3.0.4-beta.24.1v3.0.4-beta.24.2v3.0.4-beta.24.3v3.0.4-beta.24.4v3.0.4-beta.25v3.0.4-beta.25.1v3.0.4-beta.25.2v3.0.4-beta.26v3.0.4-beta.27v3.0.4-beta.28v3.0.4-beta.3v3.0.4-beta.4
3.3.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0602 is a high vulnerability (CVSS 7.4) in Tastyigniter, published April 5, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.72%, the 54th percentile. Fixed in tastyigniter/tastyigniter 3.3.0.

References

This page doesn't list everything

Left out here: 17 versions. The JSON record has them.

MoveEnter Open