Every CVE Search/ Get API key

CVE-2022-0623

Out-of-bounds Read in mruby/mruby

6.5 Medium

Out-of-bounds Read in Homebrew mruby prior to 3.2.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
Low

Exploit likelihood

1.64%Up 0.8 points since Feb 17, 2022
90%50%10%1%

What each source reports

CVE List Score used 6.5

Out-of-bounds Read in mruby/mruby

Out-of-bounds Read in Homebrew mruby prior to 3.2.

Record
CVE-2022-0623
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
EUVDEUVD-2022-15721 6.5

Out-of-bounds Read in Homebrew mruby prior to 3.2.

Record
EUVD-2022-15721
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-ff35-7f56-3w6p No score

Out-of-bounds Read in Homebrew mruby prior to 3.2.

Out-of-bounds Read in Homebrew mruby prior to 3.2.

Record
GHSA-ff35-7f56-3w6p
Weakness
CWE-125
Updated
2026-11-02
NVD 9.1

Out-of-bounds Read in Homebrew mruby prior to 3.2.

Record
CVE-2022-0623
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
OSV 6.5

Out-of-bounds Read in mruby/mruby

Out-of-bounds Read in Homebrew mruby prior to 3.2.

Record
CVE-2022-0623
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
OSVUBUNTU-CVE-2022-0623 9.1

Out-of-bounds Read in Homebrew mruby prior to 3.2.

Record
UBUNTU-CVE-2022-0623
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Updated
2026-11-02
OSVopenSUSE-SU-2025:15333-1 No score

libmruby3_4_0-3.4.0-1.1 on GA media

These are all security issues fixed in the libmruby3_4_0-3.4.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15333-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mruby
Ubuntu:16.04:LTS
All versions, plus listed versions
1.1.0+20150817+gita1731254-11.1.0+20150906+git1cbbb7e1-11.2.0+20160315+git4f20d58a-1
None known
mruby
Ubuntu:18.04:LTS
All versions, plus listed versions
1.3.0-11.3.0+20170925+git38185028-11.3.0+20171029+git77edafb0-11.4.0-1
None known
mruby
Ubuntu:20.04:LTS
All versions, plus listed versions
2.0.0-1
None known
mruby
Ubuntu:22.04:LTS
All versions, plus listed versions
2.1.2-33.0.0-13.0.0-3
None known
mruby
Ubuntu:24.04:LTS
All versions, plus listed versions
3.2.0-13.2.0-2
None known
mruby
Ubuntu:25.10
All versions, plus listed versions
3.3.0-1
None known
mruby
Ubuntu:26.10
All versions, plus listed versions
3.4.0-23.4.0-34.0.0-1
None known
mruby
Ubuntu:26.04:LTS
All versions, plus listed versions
3.3.0-13.4.0-2
None known
mruby
openSUSE:Tumbleweed
From an advisory covering 4 CVEs
before 3.4.0-1.1
3.4.0-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0623 is a medium vulnerability (CVSS 6.5) in Mruby, published February 17, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.64%, the 76th percentile. No source names a fixed version.

References

Show 5 moreShow less
MoveEnter Open