Every CVE Search/ Get API key

CVE-2022-0635

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific...

7.5 HighFix available

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion check.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.37%Up 0.5 points since Mar 24, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.5

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion check.

Record
CVE-2022-0635
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
EUVDEUVD-2022-15732 7.5

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion check.

Record
EUVD-2022-15732
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-q778-7mc2-5qmc 7.5

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific...

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion check.

Record
GHSA-q778-7mc2-5qmc
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-617
Updated
2026-11-02
NVD 7.5

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion check.

Record
CVE-2022-0635
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-617
Updated
2026-11-02
OSVBELL-CVE-2022-0635 7.5

CVE-2022-0635 does not affect BellSoft software

Record
BELL-CVE-2022-0635
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion check.

Record
CVE-2022-0635
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2022-0635 7.5

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion check.

Record
DEBIAN-CVE-2022-0635
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-0635 7.5

Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion check.

Record
UBUNTU-CVE-2022-0635
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:12081-1 No score

bind-9.18.2-1.1 on GA media

These are all security issues fixed in the bind-9.18.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12081-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
bind9
Debian:12
before 1:9.18.1-1
1:9.18.1-1
bind9
Debian:13
before 1:9.18.1-1
1:9.18.1-1
bind9
Debian:14
before 1:9.18.1-1
1:9.18.1-1
bind9
Ubuntu:22.04:LTS
before 1:9.18.0-2ubuntu3, plus listed versions
1:9.16.15-1ubuntu11:9.16.15-1ubuntu21:9.16.15-1ubuntu31:9.18.0-2ubuntu11:9.18.0-2ubuntu2
1:9.18.0-2ubuntu3
bind
openSUSE:Tumbleweed
From an advisory covering 4 CVEs
before 9.18.2-1.1
9.18.2-1.1

History

History
RecordedChangedSources
affected, factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0635 is a high vulnerability (CVSS 7.5) in Isc Bind, published March 16, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.37%, the 72nd percentile. Fixed in bind9 1:9.18.1-1.

References

Show 6 moreShow less
MoveEnter Open