Every CVE Search/ Get API key

CVE-2022-0660

Generation of Error Message Containing Sensitive Information in microweber/microweber

9.4 CriticalFix available

Generation of Error Message Containing Sensitive Information in Packagist microweber/microweber prior to 1.2.11.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
Low

Exploit likelihood

6.92%Up 6.0 points since Feb 19, 2022
90%50%10%1%

What each source reports

CVE List Score used 9.4

Generation of Error Message Containing Sensitive Information in microweber/microweber

Generation of Error Message Containing Sensitive Information in Packagist microweber/microweber prior to 1.2.11.

Record
CVE-2022-0660
CVSS 3.0
9.4 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
Weakness
CWE-209
Updated
2026-11-02
EUVDEUVD-2022-1047 9.4

Generation of Error Message Containing Sensitive Information in Packagist microweber/microweber prior to 1.2.11.

Record
EUVD-2022-1047
CVSS 3.0
9.4 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-hhrj-wp42-32v3 7.5

Generation of Error Message Containing Sensitive Information in microweber

Generation of Error Message Containing Sensitive Information in Packagist microweber/microweber prior to 1.2.11.

Record
GHSA-hhrj-wp42-32v3
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-209
Updated
2026-11-02
NVD 7.5

Generation of Error Message Containing Sensitive Information in Packagist microweber/microweber prior to 1.2.11.

Record
CVE-2022-0660
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 3.0
9.4 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-209
Updated
2026-11-02
OSV 9.4

Generation of Error Message Containing Sensitive Information in microweber/microweber

Generation of Error Message Containing Sensitive Information in Packagist microweber/microweber prior to 1.2.11.

Record
CVE-2022-0660
CVSS 3.0
9.4 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
Weakness
CWE-209
Updated
2026-11-02
OSVGHSA-hhrj-wp42-32v3 7.5

Generation of Error Message Containing Sensitive Information in microweber

Generation of Error Message Containing Sensitive Information in Packagist microweber/microweber prior to 1.2.11.

Record
GHSA-hhrj-wp42-32v3
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-209
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
microweber/microweber
Packagist
before 1.2.11
1.2.11
microweber/microweber
Packagist
before 1.2.11, plus listed versions
0.9.3460.930.9310.9340.951
Show 14 moreShow less
1.0.31.0.41.0.51.0.61.0.71.1v1.2.10v1.2.3v1.2.4v1.2.5v1.2.6v1.2.7v1.2.8v1.2.9
1.2.11

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
NucleiMicroweber <1.2.11 - Information Disclosure

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, Nuclei, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0660 is a critical vulnerability (CVSS 9.4) in Microweber, published February 18, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.92%, the 94th percentile. Fixed in microweber/microweber 1.2.11.

References

MoveEnter Open