CVE-2022-0678
Cross-site Scripting (XSS) - Reflected in microweber/microweber
Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Cross-site Scripting (XSS) - Reflected in microweber/microweber
Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.
- Record
CVE-2022-0678- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-0782
6.5
Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.
- Record
EUVD-2022-0782- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-38m9-3vg4-rwvp
6.5
Cross-site Scripting in microweber
microweber prior to version 1.2.11 is vulnerable to cross-site scripting.
- Record
GHSA-38m9-3vg4-rwvp- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
6.1
Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.
- Record
CVE-2022-0678- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.5
Cross-site Scripting (XSS) - Reflected in microweber/microweber
Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.
- Record
CVE-2022-0678- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-38m9-3vg4-rwvp
6.5
Cross-site Scripting in microweber
microweber prior to version 1.2.11 is vulnerable to cross-site scripting.
- Record
GHSA-38m9-3vg4-rwvp- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
microweber/microweberPackagist |
before 1.2.11 | 1.2.11 |
microweber/microweberPackagist |
before 1.2.11, plus listed versions 0.9.3460.930.9310.9340.951 Show 14 moreShow less1.0.31.0.41.0.51.0.61.0.71.1v1.2.10v1.2.3v1.2.4v1.2.5v1.2.6v1.2.7v1.2.8v1.2.9 |
1.2.11 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Nuclei | Microweber <1.2.11 - Cross-Site Scripting |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Nuclei, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0678 is a medium vulnerability (CVSS 6.5) in Microweber, published February 19, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.27%, the 83rd percentile. Fixed in microweber/microweber 1.2.11.
References
huntr.dev/bounties/d707137a-aace-44c5-b15c-1807035716c0
github.com/microweber/microweber/commit/2b8fa5aac31e51e2aca83c7ef5d1281ba2e755f8
nvd.nist.gov/vuln/detail/CVE-2022-0678
github.com/advisories/GHSA-38m9-3vg4-rwvp
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0678.json
github.com/microweber/microweber