CVE-2022-0688
Business Logic Errors in microweber/microweber
Business Logic Errors in Packagist microweber/microweber prior to 1.2.11.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.4
Business Logic Errors in microweber/microweber
Business Logic Errors in Packagist microweber/microweber prior to 1.2.11.
- Record
CVE-2022-0688- CVSS 3.0
- 9.4 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:H - Weakness
- CWE-840
- Updated
- 2026-11-02
EUVDEUVD-2022-0954
9.4
Business Logic Errors in Packagist microweber/microweber prior to 1.2.11.
- Record
EUVD-2022-0954- CVSS 3.0
- 9.4 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c5gj-w4hx-gvmx
2.7
Business Logic Errors in microweber
Microweber prior to 1.2.11 can suffer from insecure direct object reference(s). A malicious actor can remove items from a victim's cart.
- Record
GHSA-c5gj-w4hx-gvmx- CVSS 3.1
- 2.7 Low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
NVD
4.9
Business Logic Errors in Packagist microweber/microweber prior to 1.2.11.
- Record
CVE-2022-0688- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N - CVSS 3.0
- 9.4 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:H - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-840
- Updated
- 2026-11-02
OSV
9.4
Business Logic Errors in microweber/microweber
Business Logic Errors in Packagist microweber/microweber prior to 1.2.11.
- Record
CVE-2022-0688- CVSS 3.0
- 9.4 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:H - Weakness
- CWE-840
- Updated
- 2026-11-02
OSVGHSA-c5gj-w4hx-gvmx
2.7
Business Logic Errors in microweber
Microweber prior to 1.2.11 can suffer from insecure direct object reference(s). A malicious actor can remove items from a victim's cart.
- Record
GHSA-c5gj-w4hx-gvmx- CVSS 3.1
- 2.7 Low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
microweber/microweberPackagist |
before 1.2.11 | 1.2.11 |
microweber/microweberPackagist |
before 1.2.11, plus listed versions 0.9.3460.930.9310.9340.951 Show 14 moreShow less1.0.31.0.41.0.51.0.61.0.71.1v1.2.10v1.2.3v1.2.4v1.2.5v1.2.6v1.2.7v1.2.8v1.2.9 |
1.2.11 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0688 is a critical vulnerability (CVSS 9.4) in Microweber, published February 20, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.92%, the 60th percentile. Fixed in microweber/microweber 1.2.11.
References
huntr.dev/bounties/051ec6d4-0b0a-41bf-9ded-27813037c9c9
github.com/microweber/microweber/commit/a41f0fddaf08ff12b2b82506b1ca9490c93ab605
nvd.nist.gov/vuln/detail/CVE-2022-0688
github.com/advisories/GHSA-c5gj-w4hx-gvmx
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0688.json
github.com/microweber/microweber