CVE-2022-0985
Improper Authentication in moodle
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
- Record
CVE-2022-0985- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-287, CWE-863
- Updated
- 2026-11-02
CVE List No score
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
- Record
CVE-2022-0985- Weakness
- CWE-287
- Updated
- 2026-11-02
EUVDEUVD-2022-1651 No score
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
- Record
EUVD-2022-1651- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6q9g-3vfq-q2qj
4.3
Improper Authentication in moodle
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
- Record
GHSA-6q9g-3vfq-q2qj- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-287, CWE-863
- Updated
- 2026-11-02
OSVGHSA-6q9g-3vfq-q2qj
4.3
Improper Authentication in moodle
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
- Record
GHSA-6q9g-3vfq-q2qj- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-287, CWE-863
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-0985
4.3
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
- Record
UBUNTU-CVE-2022-0985- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVBIT-moodle-2022-0985 No score
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
- Record
BIT-moodle-2022-0985- Updated
- 2026-11-02
OSV No score
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
- Record
CVE-2022-0985- Weakness
- CWE-287
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
3.11.0 up to 3.11.6 | 3.11.6 |
moodle/moodlePackagist |
3.10.0 up to 3.10.10 | 3.10.10 |
moodle/moodlePackagist |
3.9 up to 3.9.13 | 3.9.13 |
moodleBitnami |
before 3.9.13, 3.10.0 up to 3.10.10, 3.11.0 up to 3.11.6 | 3.9.133.10.103.11.6 |
moodle/moodlePackagist |
3.11.0 up to 3.11.6, plus listed versions v3.11.0v3.11.1v3.11.2v3.11.3v3.11.4v3.11.5 |
3.11.6 |
moodle/moodlePackagist |
3.10.0 up to 3.10.10, plus listed versions v3.10.0v3.10.1v3.10.2v3.10.3v3.10.4 Show 5 moreShow lessv3.10.5v3.10.6v3.10.7v3.10.8v3.10.9 |
3.10.10 |
moodle/moodlePackagist |
3.9 up to 3.9.13, plus listed versions v3.9.0v3.9.0-betav3.9.0-rc1v3.9.0-rc2v3.9.0-rc3 Show 12 moreShow lessv3.9.1v3.9.10v3.9.11v3.9.12v3.9.2v3.9.3v3.9.4v3.9.5v3.9.6v3.9.7v3.9.8v3.9.9 |
3.9.13 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0985 is a medium vulnerability (CVSS 4.3) in Moodle, published April 29, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.56%, the 46th percentile. Fixed in moodle/moodle 3.11.6.
References
bugzilla.redhat.com/show_bug.cgi?id=2064117
nvd.nist.gov/vuln/detail/CVE-2022-0985
github.com/moodle/moodle/commit/addd4f894d8173ec8ff0ae2212d51a1977e7bcad
github.com/advisories/GHSA-6q9g-3vfq-q2qj
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0985.json
github.com/moodle/moodle
ubuntu.com/security/CVE-2022-0985
cve.org/CVERecord?id=CVE-2022-0985