CVE-2022-1201
NULL Pointer Dereference in mrb_vm_exec with super in mruby/mruby
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.1
NULL Pointer Dereference in mrb_vm_exec with super in mruby/mruby
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
- Record
CVE-2022-1201- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
EUVDEUVD-2022-24541
7.1
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
- Record
EUVD-2022-24541- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p2wj-9vfc-2xj7
6.5
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2....
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
- Record
GHSA-p2wj-9vfc-2xj7- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
NVD
6.5
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
- Record
CVE-2022-1201- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H - CVSS 3.0
- 7.1 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H - CVSS 2.0
- 4.9 Medium
AV:L/AC:L/Au:N/C:N/I:N/A:C - Weakness
- CWE-476
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-1201
6.5
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
- Record
ALPINE-CVE-2022-1201- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H - Updated
- 2026-11-03
OSVAZL-41093
6.5
CVE-2022-1201 affecting package rust for versions less than 1.75.0-1
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
- Record
AZL-41093- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H - Updated
- 2026-11-05
OSV
7.1
NULL Pointer Dereference in mrb_vm_exec with super in mruby/mruby
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
- Record
CVE-2022-1201- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-1201
6.5
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
- Record
DEBIAN-CVE-2022-1201- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-1201
6.5
NULL Pointer Dereference in mrb_vm_exec with super in GitHub repository mruby/mruby prior to 3.2. This vulnerability is capable of making the mruby interpreter crash, thus affecting the availability of the system.
- Record
UBUNTU-CVE-2022-1201- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H - CVSS 3.0
- 7.1 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mrubyAlpine:v3.17 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.18 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.19 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.20 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.21 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.22 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.23 |
before 3.1.0-r0 | 3.1.0-r0 |
mrubyAlpine:v3.24 |
before 3.1.0-r0 | 3.1.0-r0 |
rustAzure Linux:3 |
before 1.75.0-1 | 1.75.0-1 |
mrubyDebian:12 |
before 3.1.0-1 | 3.1.0-1 |
Show 10 moreShow less
| Package | Affected | Fixed |
|---|---|---|
mrubyDebian:13 |
before 3.1.0-1 | 3.1.0-1 |
mrubyDebian:14 |
before 3.1.0-1 | 3.1.0-1 |
mrubyUbuntu:16.04:LTS |
All versions, plus listed versions 1.1.0+20150817+gita1731254-11.1.0+20150906+git1cbbb7e1-11.2.0+20160315+git4f20d58a-1 |
None known |
mrubyUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.0-11.3.0+20170925+git38185028-11.3.0+20171029+git77edafb0-11.4.0-1 |
None known |
mrubyUbuntu:20.04:LTS |
All versions, plus listed versions 2.0.0-1 |
None known |
mrubyUbuntu:22.04:LTS |
All versions, plus listed versions 2.1.2-33.0.0-13.0.0-3 |
None known |
mrubyUbuntu:24.04:LTS |
All versions, plus listed versions 3.2.0-13.2.0-2 |
None known |
mrubyUbuntu:25.10 |
All versions, plus listed versions 3.3.0-1 |
None known |
mrubyUbuntu:26.10 |
All versions, plus listed versions 3.4.0-23.4.0-34.0.0-1 |
None known |
mrubyUbuntu:26.04:LTS |
All versions, plus listed versions 3.3.0-13.4.0-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| affected, aliases, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-1201 is a high vulnerability (CVSS 7.1) in Mruby, published April 2, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.37%, the 30th percentile. Fixed in mruby 3.1.0-r0.
References
huntr.dev/bounties/6f930add-c9d8-4870-ae56-d4bd8354703b
github.com/mruby/mruby/commit/00acae117da1b45b318dc36531a7b0021b8097ae
nvd.nist.gov/vuln/detail/CVE-2022-1201
github.com/advisories/GHSA-p2wj-9vfc-2xj7
security.alpinelinux.org/vuln/CVE-2022-1201
github.com/CVEProject/cvelistV5/tree/main/cves/2022/1xxx/CVE-2022-1201.json
security-tracker.debian.org/tracker/CVE-2022-1201
ubuntu.com/security/CVE-2022-1201
cve.org/CVERecord?id=CVE-2022-1201