Every CVE Search/ Get API key

CVE-2022-1237

Improper Validation of Array Index in radareorg/radare2

7.6 HighFix available

Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is heap overflow and may be exploitable. For more general description of heap buffer overflow, see CWE.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
High

Exploit likelihood

0.84%Unchanged since Apr 9, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.6

Improper Validation of Array Index in radareorg/radare2

Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is heap overflow and may be exploitable. For more general description of heap buffer overflow, see CWE.

Record
CVE-2022-1237
CVSS 3.0
7.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H
Weakness
CWE-129
Updated
2026-11-02
EUVDEUVD-2022-24572 7.6

Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is heap overflow and may be exploitable. For more general description of heap buffer overflow, see CWE.

Record
EUVD-2022-24572
CVSS 3.0
7.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-4mjq-hx99-8pp5 7.8

Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This...

Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is heap overflow and may be exploitable. For more general description of heap buffer overflow, see CWE.

Record
GHSA-4mjq-hx99-8pp5
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-129
Updated
2026-11-02
NVD 7.8

Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is heap overflow and may be exploitable. For more general description of heap buffer overflow, see CWE.

Record
CVE-2022-1237
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
7.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-129
Updated
2026-11-02
OSVALPINE-CVE-2022-1237 7.8

Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is heap overflow and may be exploitable. For more general description of heap buffer overflow, see CWE.

Record
ALPINE-CVE-2022-1237
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 7.6

Improper Validation of Array Index in radareorg/radare2

Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is heap overflow and may be exploitable. For more general description of heap buffer overflow, see CWE.

Record
CVE-2022-1237
CVSS 3.0
7.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H
Weakness
CWE-129
Updated
2026-11-02
OSVUBUNTU-CVE-2022-1237 7.8

Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is heap overflow and may be exploitable. For more general description of heap buffer overflow, see CWE.

Record
UBUNTU-CVE-2022-1237
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
7.6 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:12173-1 No score

radare2-5.7.0-1.1 on GA media

These are all security issues fixed in the radare2-5.7.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12173-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
radare2
Alpine:v3.18
before 5.6.8-r0
5.6.8-r0
radare2
Alpine:v3.19
before 5.6.8-r0
5.6.8-r0
radare2
Alpine:v3.20
before 5.6.8-r0
5.6.8-r0
radare2
Alpine:v3.21
before 5.6.8-r0
5.6.8-r0
radare2
Alpine:v3.22
before 5.6.8-r0
5.6.8-r0
radare2
Alpine:v3.23
before 5.6.8-r0
5.6.8-r0
radare2
Alpine:v3.24
before 5.6.8-r0
5.6.8-r0
radare2
Ubuntu:16.04:LTS
All versions, plus listed versions
0.9.6-3.1ubuntu1
None known
radare2
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
1.6.0+dfsg-12.0.0+dfsg-12.1.0+dfsg-12.3.0+dfsg-12.3.0+dfsg-22.3.0+dfsg-2ubuntu0.1~esm1
None known
radare2
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
3.2.1+dfsg-5build14.0.0+dfsg-14.2.1+dfsg-14.2.1+dfsg-24.2.1+dfsg-2ubuntu0.1~esm1
None known
Show 5 moreShow less
Affected packages
PackageAffectedFixed
radare2
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
5.5.0+dfsg-1ubuntu15.5.0+dfsg-1.1ubuntu25.5.0+dfsg-1.1ubuntu35.5.0+dfsg-1.1ubuntu3+esm1
None known
radare2
Ubuntu:25.10
All versions, plus listed versions
5.9.8+dfsg-25.9.8+dfsg-2ubuntu0.25.10.15.9.8+dfsg-2ubuntu0.25.10.2
None known
radare2
Ubuntu:26.10
All versions, plus listed versions
6.0.7+ds-16.1.6+ds-26.1.6+ds-36.1.8+ds-1
None known
radare2
Ubuntu:26.04:LTS
All versions, plus listed versions
5.9.8+dfsg-26.0.4+dfsg-16.0.7+ds-1
None known
radare2
openSUSE:Tumbleweed
From an advisory covering 38 CVEs
before 5.7.0-1.1
5.7.0-1.1

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-1237 is a high vulnerability (CVSS 7.6) in Radare Radare2, published April 6, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.84%, the 58th percentile. Fixed in radare2 5.6.8-r0.

References

Show 40 moreShow less
MoveEnter Open