Every CVE Search/ Get API key

CVE-2022-21222

Regular Expression Denial of Service (ReDoS)

5.3 MediumFix available

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

1.90%Up 1.0 points since Sep 30, 2022
90%50%10%1%

What each source reports

CVE List Score used 5.3

Regular Expression Denial of Service (ReDoS)

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Record
CVE-2022-21222
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P
Weakness
CWE-1333
Updated
2026-11-02
EUVDEUVD-2022-7138 5.3

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Record
EUVD-2022-7138
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P
Updated
2026-11-02
GitHub AdvisoriesGHSA-p28h-cc7q-c4fg 7.5

css-what vulnerable to ReDoS due to use of insecure regular expression

The package css-what before 2.1.3 is vulnerable to Regular Expression Denial of Service (ReDoS) due to the use of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Record
GHSA-p28h-cc7q-c4fg
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400, CWE-1333
Updated
2026-11-02
NVD 5.3

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Record
CVE-2022-21222
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-1333
Updated
2026-11-02
OSV 5.3

Regular Expression Denial of Service (ReDoS)

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Record
CVE-2022-21222
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P
Updated
2026-11-02
OSVDEBIAN-CVE-2022-21222 7.5

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Record
DEBIAN-CVE-2022-21222
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVGHSA-p28h-cc7q-c4fg 7.5

css-what vulnerable to ReDoS due to use of insecure regular expression

The package css-what before 2.1.3 is vulnerable to Regular Expression Denial of Service (ReDoS) due to the use of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Record
GHSA-p28h-cc7q-c4fg
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-1333, CWE-400
Updated
2026-11-02
OSVUBUNTU-CVE-2022-21222 5.3

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Record
UBUNTU-CVE-2022-21222
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-6065-1 No score

node-css-what vulnerabilities

It was discovered that css-what incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to cause a denial of service. (CVE-2021-33587, CVE-2022-21222)

Record
USN-6065-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
css-what
npm
before 2.1.3
2.1.3
node-css-what
Debian:12
before 5.0.1-1
5.0.1-1
node-css-what
Debian:13
before 5.0.1-1
5.0.1-1
node-css-what
Debian:14
before 5.0.1-1
5.0.1-1
node-css-what
Debian:10
From an advisory covering 2 CVEs
before 2.1.0-1+deb10u1, plus listed versions
2.1.0-1
2.1.0-1+deb10u1
node-css-what
Ubuntu:Pro:16.04:LTS
before 2.1.0-1ubuntu0.16.04.1~esm1, plus listed versions
2.0.2-12.1.0-1
2.1.0-1ubuntu0.16.04.1~esm1
node-css-what
Ubuntu:18.04:LTS
before 2.1.0-1+deb10u1build0.18.04.1, plus listed versions
2.1.0-1
2.1.0-1+deb10u1build0.18.04.1
node-css-what
Ubuntu:Pro:20.04:LTS
before 3.2.1-1ubuntu0.1~esm1, plus listed versions
3.1.0-23.2.0-13.2.1-1
3.2.1-1ubuntu0.1~esm1
node-css-what
Ubuntu:24.04:LTS
All versions, plus listed versions
6.1.0-5
None known
node-css-what
Ubuntu:25.10
All versions, plus listed versions
6.1.0-5
None known
Show 5 moreShow less
Affected packages
PackageAffectedFixed
node-css-what
Ubuntu:26.10
All versions, plus listed versions
6.1.0-56.2.2-26.2.2-3
None known
node-css-what
Ubuntu:26.04:LTS
All versions, plus listed versions
6.1.0-5
None known
node-css-what
Ubuntu:Pro:16.04:LTS
From an advisory covering 2 CVEs
before 2.1.0-1ubuntu0.16.04.1~esm1, plus listed versions
2.0.2-12.1.0-1
2.1.0-1ubuntu0.16.04.1~esm1
node-css-what
Ubuntu:18.04:LTS
From an advisory covering 2 CVEs
before 2.1.0-1+deb10u1build0.18.04.1, plus listed versions
2.1.0-1
2.1.0-1+deb10u1build0.18.04.1
node-css-what
Ubuntu:Pro:20.04:LTS
From an advisory covering 2 CVEs
before 3.2.1-1ubuntu0.1~esm1, plus listed versions
3.1.0-23.2.0-13.2.1-1
3.2.1-1ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, factsOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-21222 is a medium vulnerability (CVSS 5.3) in Css-what Project Css-what, published September 30, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.90%, the 79th percentile. Fixed in css-what 2.1.3.

References

Show 8 moreShow less
MoveEnter Open