Every CVE Search/ Get API key

CVE-2022-21227

Denial of Service (DoS)

7.5 HighFix available

The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.21%Up 1.3 points since May 2, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.5

Denial of Service (DoS)

The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.

Record
CVE-2022-21227
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P
Updated
2026-11-02
EUVDEUVD-2022-1694 7.5

The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.

Record
EUVD-2022-1694
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P
Updated
2026-11-03
GitHub AdvisoriesGHSA-9qrh-qjmc-5w2p 7.5

Denial-of-Service when binding invalid parameters in sqlite3

Affected versions of sqlite3 will experience a fatal error when supplying a specific object in the parameter array. This error causes the application to crash and could not be caught. Users of sqlite3 v5.0.0, v5.0.1 and v5.0.2 are affected by this. This issue is fixed in v5.0.3. All users are recommended to upgrade to v5.0.3 or later. Ensure there is sufficient sanitization in the parent application to protect against invalid values being supplied to binding parameters as a workaround.

Record
GHSA-9qrh-qjmc-5w2p
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-248
Updated
2026-11-02
NVD 7.5

The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.

Record
CVE-2022-21227
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
OSV 7.5

Denial of Service (DoS)

The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.

Record
CVE-2022-21227
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P
Updated
2026-11-02
OSVDEBIAN-CVE-2022-21227 7.5

The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.

Record
DEBIAN-CVE-2022-21227
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVGHSA-9qrh-qjmc-5w2p 7.5

Denial-of-Service when binding invalid parameters in sqlite3

Affected versions of sqlite3 will experience a fatal error when supplying a specific object in the parameter array. This error causes the application to crash and could not be caught. Users of sqlite3 v5.0.0, v5.0.1 and v5.0.2 are affected by this. This issue is fixed in v5.0.3. All users are recommended to upgrade to v5.0.3 or later. Ensure there is sufficient sanitization in the parent application to protect against invalid values being supplied to binding parameters as a workaround.

Record
GHSA-9qrh-qjmc-5w2p
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-248
Updated
2026-11-02
OSVUBUNTU-CVE-2022-21227 7.5

The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.

Record
UBUNTU-CVE-2022-21227
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sqlite3
npm
5.0.0 up to 5.0.3
5.0.3
node-sqlite3
Debian:12
before 5.0.6+ds1-1
5.0.6+ds1-1
node-sqlite3
Debian:13
before 5.0.6+ds1-1
5.0.6+ds1-1
node-sqlite3
Debian:14
before 5.0.6+ds1-1
5.0.6+ds1-1
node-sqlite3
Ubuntu:16.04:LTS
All versions, plus listed versions
2.2.0+ds1-1
None known
node-sqlite3
Ubuntu:18.04:LTS
All versions, plus listed versions
3.1.8+ds1-2build13.1.8+ds1-2build2
None known
node-sqlite3
Ubuntu:20.04:LTS
All versions, plus listed versions
4.0.6+ds1-24.1.0+ds1-14.1.1+ds1-14.1.1+ds1-1build1
None known
node-sqlite3
Ubuntu:22.04:LTS
All versions, plus listed versions
5.0.0+ds1-15.0.2+ds1-3
None known

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-21227 is a high vulnerability (CVSS 7.5) in Ghost Sqlite3, published April 28, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.21%, the 82nd percentile. Fixed in sqlite3 5.0.3.

References

Show 8 moreShow less
MoveEnter Open