CVE-2022-22704
The zabbix-agent2 package before 5.4.9-r1 for Alpine Linux sometimes allows privilege escalation...
The zabbix-agent2 package before 5.4.9-r1 for Alpine Linux sometimes allows privilege escalation to root because the design incorrectly expected that systemd would (in effect) determine part of the configuration.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The zabbix-agent2 package before 5.4.9-r1 for Alpine Linux sometimes allows privilege escalation to root because the design incorrectly expected that systemd would (in effect) determine part of the configuration.
- Record
CVE-2022-22704- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-909
- Updated
- 2026-11-02
CVE List No score
The zabbix-agent2 package before 5.4.9-r1 for Alpine Linux sometimes allows privilege escalation to root because the design incorrectly expected that systemd would (in effect) determine part of the configuration.
- Record
CVE-2022-22704- Updated
- 2026-11-02
EUVDEUVD-2022-27847 No score
The zabbix-agent2 package before 5.4.9-r1 for Alpine Linux sometimes allows privilege escalation to root because the design incorrectly expected that systemd would (in effect) determine part of the configuration.
- Record
EUVD-2022-27847- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rgf9-28hg-x4c8
9.8
The zabbix-agent2 package before 5.4.9-r1 for Alpine Linux sometimes allows privilege escalation...
The zabbix-agent2 package before 5.4.9-r1 for Alpine Linux sometimes allows privilege escalation to root because the design incorrectly expected that systemd would (in effect) determine part of the configuration.
- Record
GHSA-rgf9-28hg-x4c8- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-22704
9.8
The zabbix-agent2 package before 5.4.9-r1 for Alpine Linux sometimes allows privilege escalation to root because the design incorrectly expected that systemd would (in effect) determine part of the configuration.
- Record
ALPINE-CVE-2022-22704- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zabbixAlpine:v3.14 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.15 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.16 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.17 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.18 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.19 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.20 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.21 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.22 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.23 |
before 5.4.9-r1 | 5.4.9-r1 |
zabbixAlpine:v3.24 |
before 5.4.9-r1 | 5.4.9-r1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, facts, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-22704 is a critical vulnerability (CVSS 9.8) in Zabbix Zabbix-agent2, published January 6, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.38%, the 72nd percentile. Fixed in zabbix 5.4.9-r1.