CVE-2022-23318
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory...
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.1
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.
- Record
CVE-2022-23318- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.
- Record
CVE-2022-23318- Updated
- 2026-11-02
EUVDEUVD-2022-28400 No score
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.
- Record
EUVD-2022-28400- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mhwp-x94h-mg49 No score
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory...
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.
- Record
GHSA-mhwp-x94h-mg49- Weakness
- CWE-787
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-23318
7.1
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.
- Record
UBUNTU-CVE-2022-23318- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSV No score
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.
- Record
CVE-2022-23318- Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-23318 No score
A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.
- Record
DEBIAN-CVE-2022-23318- Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pcf2bdfDebian:12 |
before 1.07-1 | 1.07-1 |
pcf2bdfDebian:13 |
before 1.07-1 | 1.07-1 |
pcf2bdfDebian:14 |
before 1.07-1 | 1.07-1 |
pcf2bdfUbuntu:16.04:LTS |
All versions, plus listed versions 1.05-1 |
None known |
pcf2bdfUbuntu:18.04:LTS |
All versions, plus listed versions 1.05-11.05-1build1 |
None known |
pcf2bdfUbuntu:20.04:LTS |
All versions, plus listed versions 1.05-1build11.05-1build2 |
None known |
pcf2bdfUbuntu:22.04:LTS |
All versions, plus listed versions 1.06-11.06-21.06-31.06-4 |
None known |
pcf2bdfUbuntu:24.04:LTS |
All versions, plus listed versions 1.07-1 |
None known |
pcf2bdfUbuntu:25.10 |
All versions, plus listed versions 1.07-1 |
None known |
pcf2bdfUbuntu:26.10 |
All versions, plus listed versions 1.07-1build1 |
None known |
pcf2bdfUbuntu:26.04:LTS |
All versions, plus listed versions 1.07-11.07-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-23318 is a high vulnerability (CVSS 7.1) in Pcf2bdf Project Pcf2bdf, published February 17, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.79%, the 56th percentile. Fixed in pcf2bdf 1.07-1.
References
github.com/ganaware/pcf2bdf
github.com/ganaware/pcf2bdf/issues/4
nvd.nist.gov/vuln/detail/CVE-2022-23318
github.com/advisories/GHSA-mhwp-x94h-mg49
github.com/CVEProject/cvelistV5/tree/main/cves/2022/23xxx/CVE-2022-23318.json
security-tracker.debian.org/tracker/CVE-2022-23318
ubuntu.com/security/CVE-2022-23318
cve.org/CVERecord?id=CVE-2022-23318