CVE-2022-23944
Apache ShenYu 2.4.1 Improper access control
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
9.1
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.
- Record
CVE-2022-23944- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:P/A:N - Weakness
- CWE-862, CWE-306
- Updated
- 2026-11-02
CVE List No score
Apache ShenYu 2.4.1 Improper access control
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.
- Record
CVE-2022-23944- Weakness
- CWE-862
- Updated
- 2026-11-02
EUVDEUVD-2022-0487 No score
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.
- Record
EUVD-2022-0487- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6v39-p2xq-g5c3
9.1
Missing authentication in ShenYu
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.
- Record
GHSA-6v39-p2xq-g5c3- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-306, CWE-862
- Updated
- 2026-11-02
OSVGHSA-6v39-p2xq-g5c3
9.1
Missing authentication in ShenYu
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.
- Record
GHSA-6v39-p2xq-g5c3- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-306, CWE-862
- Updated
- 2026-11-02
OSV No score
Apache ShenYu 2.4.1 Improper access control
User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.
- Record
CVE-2022-23944- Weakness
- CWE-862
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.shenyu:shenyu-commonMaven |
2.4.0 up to 2.4.2 | 2.4.2 |
org.apache.shenyu:shenyu-commonMaven |
2.4.0 up to 2.4.2, plus listed versions 2.4.1 |
2.4.2 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Nuclei | Apache ShenYu Admin Unauth Access |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Nuclei, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-23944 is a critical vulnerability (CVSS 9.1) in Apache Shenyu, published January 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 79.0%, the 99th percentile. Fixed in org.apache.shenyu:shenyu-common 2.4.2.