Every CVE Search/ Get API key

CVE-2022-24112

apisix/batch-requests plugin allows overwriting the X-REAL-IP header

9.8 CriticalIn KEVPublic exploitFix available

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

96.1%Up 92.1 points since Feb 12, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Record
CVE-2022-24112
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-290
Updated
2026-11-02
CVE List 9.8

apisix/batch-requests plugin allows overwriting the X-REAL-IP header

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Record
CVE-2022-24112
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-290
Updated
2026-11-02
EUVDEUVD-2022-29024 9.8

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Record
EUVD-2022-29024
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-2vc7-6w39-6rh2 9.8

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of...

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Record
GHSA-2vc7-6w39-6rh2
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-290
Updated
2026-11-02
CISA KEV No score

Apache APISIX Authentication Bypass Vulnerability

Apache APISIX contains an authentication bypass vulnerability that allows for remote code execution.

Record
CVE-2022-24112
Weakness
CWE-290
Updated
2026-11-02
OSV 9.8

apisix/batch-requests plugin allows overwriting the X-REAL-IP header

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Record
CVE-2022-24112
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-290
Updated
2026-11-02
OSVBIT-apisix-2022-24112 No score

apisix/batch-requests plugin allows overwriting the X-REAL-IP header

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Record
BIT-apisix-2022-24112
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apisix
Bitnami
before 2.10.4, 2.11.0 up to 2.12.1
2.10.42.12.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
MetasploitAPISIX Admin API default access token RCE2020-12-07
PoC in GitHubCrackerCat/CVE-2022-241122022-02-22
PoC in GitHubMr-xn/CVE-2022-241122022-02-22
PoC in GitHubSecNN/CVE-2022-241122022-02-25
PoC in GitHubMah1ndra/CVE-2022-241122022-03-08
Exploit-DBApache APISIX 2.12.1 - Remote Code Execution (RCE)2022-03-16
PoC in GitHubkavishkagihan/CVE-2022-24112-POC2022-03-17
PoC in GitHubtwseptian/cve-2022-241122022-03-20
PoC in GitHubAcczdy/CVE-2022-24112_POC2022-12-03
PoC in GitHubbtar1gan/exploit_CVE-2022-241122024-06-03
PoC in GitHubfatkz/CVE-2022-241122025-05-23
NucleiApache APISIX - Remote Code Execution

History

History
RecordedChangedSources
exploitsPoC in GitHub
exploitation, exploits
first indexedCVE List, EUVD, Exploit-DB, GitHub Advisories, CISA KEV, Metasploit, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-24112 is a critical vulnerability (CVSS 9.8) in Apache Apisix, published February 11, 2022. CISA lists it as known to be exploited, since August 25, 2022. EUVD reports exploitation since August 25, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 96.1%, the 99th percentile. Fixed in apisix 2.10.4.

References

MoveEnter Open