CVE-2022-2470
Cross-site Scripting (XSS) - Reflected in microweber/microweber
Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.21.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Cross-site Scripting (XSS) - Reflected in microweber/microweber
Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.21.
- Record
CVE-2022-2470- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-6316
6.5
Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.21.
- Record
EUVD-2022-6316- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cfcg-2qgr-v243
6.1
Microweber before 1.2.21 vulnerable to reflected XSS
Microweber prior to 1.2.21 is vulnerable to reflected cross-site scripting (XSS).
- Record
GHSA-cfcg-2qgr-v243- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
6.1
Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.21.
- Record
CVE-2022-2470- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.5
Cross-site Scripting (XSS) - Reflected in microweber/microweber
Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.21.
- Record
CVE-2022-2470- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-cfcg-2qgr-v243
6.1
Microweber before 1.2.21 vulnerable to reflected XSS
Microweber prior to 1.2.21 is vulnerable to reflected cross-site scripting (XSS).
- Record
GHSA-cfcg-2qgr-v243- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
microweber/microweberPackagist |
before 1.2.21 | 1.2.21 |
microweber/microweberPackagist |
before 1.2.21, plus listed versions 0.9.3460.930.9310.9340.951 Show 24 moreShow less1.0.31.0.41.0.51.0.61.0.71.1v1.2.10v1.2.11v1.2.12v1.2.13v1.2.14v1.2.15v1.2.16v1.2.17v1.2.18v1.2.19v1.2.20v1.2.3v1.2.4v1.2.5v1.2.6v1.2.7v1.2.8v1.2.9 |
1.2.21 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-2470 is a medium vulnerability (CVSS 6.5) in Microweber, published July 22, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.97%, the 62nd percentile. Fixed in microweber/microweber 1.2.21.
References
huntr.dev/bounties/3f1f679c-c243-431c-8ed0-e61543b9921b
github.com/microweber/microweber/commit/d28655183800b833abb20ccd55e1628f16ff65e4
nvd.nist.gov/vuln/detail/CVE-2022-2470
github.com/advisories/GHSA-cfcg-2qgr-v243
github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2470.json
github.com/microweber/microweber