Every CVE Search/ Get API key

CVE-2022-24897

Arbitrary filesystem write access from Velocity

7.5 HighPublic exploitFix available

APIs to evaluate content with Velocity is a package for APIs to evaluate content with Velocity. Starting with version 2.3 and prior to 12.6.7, 12.10.3, and 13.0, the velocity scripts are not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Writing an attacking script in Velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File. The problem has been patched in versions 12.6.7, 12.10.3, and 13.0. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.79%Up 0.8 points since May 3, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.5

Arbitrary filesystem write access from Velocity

APIs to evaluate content with Velocity is a package for APIs to evaluate content with Velocity. Starting with version 2.3 and prior to 12.6.7, 12.10.3, and 13.0, the velocity scripts are not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Writing an attacking script in Velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File. The problem has been patched in versions 12.6.7, 12.10.3, and 13.0. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

Record
CVE-2022-24897
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-22
Updated
2026-11-02
EUVDEUVD-2022-1713 7.5

APIs to evaluate content with Velocity is a package for APIs to evaluate content with Velocity. Starting with version 2.3 and prior to 12.6.7, 12.10.3, and 13.0, the velocity scripts are not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Writing an attacking script in Velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File. The problem has been patched in versions 12.6.7, 12.10.3, and 13.0. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

Record
EUVD-2022-1713
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-cvx5-m8vg-vxgc 7.5

Arbitrary filesystem write access from velocity.

Impact

The velocity scripts is not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Now writing an attacking script in velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File.

Patches

The problem has been patched on versions 12.6.7, 12.10.3 and 13.0RC1.

Workarounds

There's no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

References

https://jira.xwiki.org/browse/XWIKI-5168

For more information

If you have any questions or comments about this advisory:

Record
GHSA-cvx5-m8vg-vxgc
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-22, CWE-668
Updated
2026-11-02
NVD 7.5

APIs to evaluate content with Velocity is a package for APIs to evaluate content with Velocity. Starting with version 2.3 and prior to 12.6.7, 12.10.3, and 13.0, the velocity scripts are not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Writing an attacking script in Velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File. The problem has been patched in versions 12.6.7, 12.10.3, and 13.0. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

Record
CVE-2022-24897
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.0 MediumAV:N/AC:M/Au:S/C:P/I:P/A:P
Weakness
CWE-22
Updated
2026-11-02
OSV 7.5

Arbitrary filesystem write access from Velocity

APIs to evaluate content with Velocity is a package for APIs to evaluate content with Velocity. Starting with version 2.3 and prior to 12.6.7, 12.10.3, and 13.0, the velocity scripts are not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Writing an attacking script in Velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File. The problem has been patched in versions 12.6.7, 12.10.3, and 13.0. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

Record
CVE-2022-24897
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-22
Updated
2026-11-02
OSVGHSA-cvx5-m8vg-vxgc 7.5

Arbitrary filesystem write access from velocity.

Impact

The velocity scripts is not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Now writing an attacking script in velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File.

Patches

The problem has been patched on versions 12.6.7, 12.10.3 and 13.0RC1.

Workarounds

There's no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

References

https://jira.xwiki.org/browse/XWIKI-5168

For more information

If you have any questions or comments about this advisory:

Record
GHSA-cvx5-m8vg-vxgc
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-22, CWE-668
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.xwiki.commons:xwiki-commons-velocity
Maven
2.3.0 up to 12.6.7
12.6.7
org.xwiki.commons:xwiki-commons-velocity
Maven
12.7.0 up to 12.10.3
12.10.3
org.xwiki.commons:xwiki-commons-velocity
Maven
2.3.0 up to 12.6.7, plus listed versions
10.010.110.1-rc-110.1010.10-rc-1
Show 45 moreShow less
10.1110.11-rc-110.11.110.11.1010.11.1110.11.210.11.310.11.410.11.510.11.610.11.710.11.810.11.910.210.310.410.4-rc-110.510.5-rc-110.610.6-rc-110.6.110.710.7-rc-110.7.110.810.8-rc-110.8.110.8.210.8.310.911.011.0.111.0.211.0.311.111.1-rc-111.1011.10.111.10.1011.10.1111.10.1211.10.1311.10.211.10.3
12.6.7
org.xwiki.commons:xwiki-commons-velocity
Maven
12.7.0 up to 12.10.3, plus listed versions
12.1012.10.112.10.212.712.7.1
Show 4 moreShow less
12.812.8-rc-112.912.9-rc-1
12.10.3

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubshoucheng3/xwiki__xwiki-commons_CVE-2022-24897_12-6-62025-08-19

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-24897 is a high vulnerability (CVSS 7.5) in Xwiki, published April 28, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.79%, the 78th percentile. Fixed in org.xwiki.commons:xwiki-commons-velocity 12.6.7.

References

This page doesn't list everything

Left out here: 262 versions. The JSON record has them.

MoveEnter Open