CVE-2022-2495
Cross-site Scripting (XSS) - Stored in microweber/microweber
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.2.21.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
6.8
Cross-site Scripting (XSS) - Stored in microweber/microweber
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.2.21.
- Record
CVE-2022-2495- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-6449
6.8
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.2.21.
- Record
EUVD-2022-6449- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xg72-6c83-ghh4
4.8
Microweber Stored Cross-site Scripting before v1.2.20
Microwerber prior to version 1.2.20 is vulnerable to stored Cross-site Scripting (XSS).
- Record
GHSA-xg72-6c83-ghh4- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
4.8
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.2.21.
- Record
CVE-2022-2495- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.8
Cross-site Scripting (XSS) - Stored in microweber/microweber
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.2.21.
- Record
CVE-2022-2495- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-xg72-6c83-ghh4
4.8
Microweber Stored Cross-site Scripting before v1.2.20
Microwerber prior to version 1.2.20 is vulnerable to stored Cross-site Scripting (XSS).
- Record
GHSA-xg72-6c83-ghh4- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
microweber/microweberPackagist |
before 1.2.20 | 1.2.20 |
microweber/microweberPackagist |
before 1.2.20, plus listed versions 0.9.3460.930.9310.9340.951 Show 23 moreShow less1.0.31.0.41.0.51.0.61.0.71.1v1.2.10v1.2.11v1.2.12v1.2.13v1.2.14v1.2.15v1.2.16v1.2.17v1.2.18v1.2.19v1.2.3v1.2.4v1.2.5v1.2.6v1.2.7v1.2.8v1.2.9 |
1.2.20 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-2495 is a medium vulnerability (CVSS 6.8) in Microweber, published July 22, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 53rd percentile. Fixed in microweber/microweber 1.2.20.
References
huntr.dev/bounties/00affb69-275d-4f4c-b419-437922bc7798
github.com/microweber/microweber/commit/d35e691e72d358430abc8e99f5ba9eb374423b9f
nvd.nist.gov/vuln/detail/CVE-2022-2495
github.com/advisories/GHSA-xg72-6c83-ghh4
github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2495.json
github.com/microweber/microweber